See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: [closed] UCGO beta test ver 091130  (Read 51369 times)

0 Members and 1 Guest are viewing this topic.

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
30 November 2009, 15:25:37
Welcome to UCGO beta test ver 091130


1-This thread is only for registered beta tester feedback, all other post will be deleted.
2-If you want to register for beta testing see below "Register for beta testing"



Current version test special instructions

It's not time to report typo but only serious bugs. If you want to correct some texts or files
(scenarios, help text) please ask before this to ensure your work will not be useless
(one file may not be finished or will be reworked, or you may be several to work on the same
correction)


Bug reporting form

Please use the text form in the link below to report bugs: It's important !
http://www.dansteph.com/publie/beta_form.txt

Please follow "your" bug and once cleared (probably with a new version) check and
confirm in beta test thread that the bug is gone. It may be a good idea to keep a
list of "your" bugs.



Feedback

Feedback are importants, please be verbous, precise, don't hesitate to write what you
think or post anything you want about beta. I'm working 12h/24h on code so sometime
I may forget the big picture. Use the form above for bugs. Keep me informed of any status
change if you can't test anymore for example.

Never forget that the final quality of addons depend enterely of YOUR TESTS.

Much thanks for your help :beer:



Registering for beta testing

Any request that doesn't follow exactly the procedure below will not be taken in account.
This ensure to have peoples able to read instructions ;)

1-Only peoples with an account here or on O-F with a minimum of 100 posts can register

2-Only peoples that have TIME for test are SERIOUS, RESPONSIVE, VERBOUS and READ instruction can apply, if it's only to get
my last addon and never come back or be silent please don't register, respect me and my work !

3-To register send me a PM here with the maximum information about you: real name, age, nickname, link to your profile here
or on O-F, your experience about beta testing and any particular information you may have. Don't forget to write also the
password "IcanReadInstructions" somewhere in the pm. ;)

Much thanks !

Dan



Message modifié ( 30-11-2009 16:02 )


Offline woo482

  • Sr. Member
  • ****
  • Posts: 266
  • Karma: 0
Reply #1 - 30 November 2009, 18:03:23

UCGO BUG


Bug with: other

Severity: CTD

Complete description
Orbiter appears to CTD on the "AI cars Dance" Scenario, normally when the truck starts to load cargo from under the arrow

Reproduce bug
load the "_UniversalCarsandCargos (UCGO) \ Features demonstrations - Learning \ AI cars Dance.scn "  after about 40 seconds
or so it should CTD

NOTE FROM DAN: it's LolaMFD that cause such CTD


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #2 - 30 November 2009, 18:12:10
Thanks for report,

I was unable to reproduce and I know other have watched the dance during a long time without problem, so it *might* be
related to another addon module. Can you disable all modules under "modules" tab of launchpad then see if it still CTD ?
If not add again the module one by one to see who's causing the problem.

Else let me know if you do anything special, changing focus etc or if it just CTD while you watch.

BTW: do you have any other UMMU addon like ISS or ShuttleA ? it might be the cause also.

Much thanks

Dan



Message modifié ( 30-11-2009 18:13 )


Offline sunshine135

  • Hero Member
  • *****
  • Posts: 547
  • Country: United States us
  • Karma: 3
  • I fly by the seat of my pants!
Reply #3 - 30 November 2009, 18:17:09

UCGO BUG


Bug with:

ISOTAP (Idiot Son of the Almighty Probe)


Short description:

Jitter in the Scenario: "Cargo- Release an exploration Probe" after probe deployment but before heat shield release


Severity

minor


Complete description

I experienced only what I could call "jitter" at 10X speed before the heat shield is released on the ISOTAP.
This may be because of my computer graphics speed. I released the probe, and it was on descent. I
decided to increase the time to 10X in an external view of the probe. The probe appeared stable in
the picture. Frame rate was about 29 to 30 FPS (good for my computer which is a laptop Dell XPS 1330 w/ NVidia 8400M GS
discrete graphics card running 256MB). The moon appeared to flicker up and down. It did not appear to cause a problem with
the probe autopilot, and after the heat shield released, this was no longer a problem. I would include a screen shot, but you
can't see the moon shaking. I did duplicate the problem. I'd like to see some feedback from other beta testers if they also
see this issue.


Reproduce bug

Run the Scenario: "Cargo- Release an exploration Probe". After the probe deploys, but before heat shield release go to 10X
speed while focused externally on the probe.


Miscallenous
Believe the issue may impact low-end graphics boards. May just require a disclaimer if a fix is not an option.


"Sun Dog"

Offline woo482

  • Sr. Member
  • ****
  • Posts: 266
  • Karma: 0
Reply #4 - 30 November 2009, 18:26:06
DanSteph: Ok I'll try doing that now


Offline the.punk

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 0
Reply #5 - 30 November 2009, 19:49:18
I think I reproduced the jitter sunshine discribed. It's a little shaking in 10x mode with the probe. And I think it
happens also after heat shield release. Will look if it happens for other vessels too.




Offline sunshine135

  • Hero Member
  • *****
  • Posts: 547
  • Country: United States us
  • Karma: 3
  • I fly by the seat of my pants!
Reply #6 - 30 November 2009, 20:39:20

UCGO BUG


Bug with:

Ummu

Short description:

Ummu has difficulty turning on lunar surface


Severity

moderate


Complete description

In the Mother ship- Arrow Freighter 18 scenario when you move the surface Ummu around, it is very difficult to get the Ummu
to turn. Forward and Back motions are fine. Turning is overly difficult to the point of annoying and reduces playability.


Reproduce bug

Run the Mother ship- Arrow Freighter 18 scenario, focus on the Ummu and attempt left or right turns on the ground. Granted,
movement on the moon should be a bit more cumbersome, but turning should not be that hard.


Miscallenous

I believe we have seen this before in previous Ummu versions and it needed a tweak to make it better. Perhaps you used some
of that earlier code Dan?


"Sun Dog"

Offline the.punk

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 0
Reply #7 - 30 November 2009, 21:10:23
Quote
sunshine135 wrote:

UCGO BUG


Bug with:

Ummu

Short description:

Ummu has difficulty turning on lunar surface


Severity

moderate


Complete description

In the Mother ship- Arrow Freighter 18 scenario when you move the surface Ummu around, it is very difficult to get
the Ummu
to turn. Forward and Back motions are fine. Turning is overly difficult to the point of annoying and reduces playability.


Reproduce bug

Run the Mother ship- Arrow Freighter 18 scenario, focus on the Ummu and attempt left or right turns on the ground.
Granted,
movement on the moon should be a bit more cumbersome, but turning should not be that hard.


Miscallenous

I believe we have seen this before in previous Ummu versions and it needed a tweak to make it better. Perhaps you
used some
of that earlier code Dan?


I looked for this and I would say that this is more like bucking. When you turn left or right and hold down the key and
then release it the UMMU is bucking.



Post Edited ( 12-01-09 20:08 )



Offline Xyon

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 0
Reply #8 - 30 November 2009, 21:34:50
Quote
DanSteph wrote:
Thanks for report,

I was unable to reproduce and I know other have watched the dance during a long time without problem, so it *might*
be
related to another addon module. Can you disable all modules under "modules" tab of launchpad then see if
it still CTD ?
If not add again the module one by one to see who's causing the problem.

Else let me know if you do anything special, changing focus etc or if it just CTD while you watch.

BTW: do you have any other UMMU addon like ISS or ShuttleA ? it might be the cause also.

Much thanks

Dan

Watched it for 300s with no problems; no other addons installed.


Offline Xyon

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 0
Reply #9 - 30 November 2009, 21:48:56

UCGO BUG


Bug with:

UMMu carrying boxes


Short description:

Minor graphics glitch; bottom of the box clips off.


Severity

Minor, detail.

Complete description

Carrying a base module in "Autoland autopilot" scenario. While in first person mode from the UMMu the box is
"clipped" through - that is, the cargo appears to be half-invisible.


Reproduce bug

Load  scenario "AutoLand autopilot". Land and release a cargo module, then EVA and pick it up with UMMu, and
change to first person mode from UMMu.


Miscallenous

Screenshot: http://xcc.rpgee.com/outlinkedpics/ucgo001.jpg



Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #10 - 30 November 2009, 22:15:58
Much thanks to all for your tests and feedbacks.

-About jitter of ISOTAP I know the cause and will work on it.

-About UMmu turning I think it might be FPS related but I'll have a look and try somes tricks. This is very strange anyway
because I use hard coded angular velocity unlike previous version. It's almost the same code than the cars. Sun any problem
with cars or all is "turning" fine ?

-About box clipped this is due to Orbiter's Z buffer I can't do anything to solve that appart putting the box further but in
this case it would look wrong in external view. Good news: you can see at least your feets so we might call that a "feature" :)

Much thanks again

Dan


Offline sunshine135

  • Hero Member
  • *****
  • Posts: 547
  • Country: United States us
  • Karma: 3
  • I fly by the seat of my pants!
Reply #11 - 30 November 2009, 22:21:25
Quote
Xyon wrote:

UCGO BUG


Bug with:

UMMu carrying boxes


Short description:

Minor graphics glitch; bottom of the box clips off.


Severity

Minor, detail.

Complete description

Carrying a base module in "Autoland autopilot" scenario. While in first person mode from the UMMu the box is
"clipped" through - that is, the cargo appears to be half-invisible.


Reproduce bug

Load  scenario "AutoLand autopilot". Land and release a cargo module, then EVA and pick it up with UMMu, and
change to first person mode from UMMu.


Miscallenous

Screenshot: http://xcc.rpgee.com/outlinkedpics/ucgo001.jpg






That is an Orbiter limitation. Th reason it appears cropped is because anything within 2.5 meters (give or take) gets cropped
and appears transparent.


"Sun Dog"

Offline sunshine135

  • Hero Member
  • *****
  • Posts: 547
  • Country: United States us
  • Karma: 3
  • I fly by the seat of my pants!
Reply #12 - 30 November 2009, 22:25:13
Quote
DanSteph wrote:

-About UMmu turning I think it might be FPS related but I'll have a look and try somes tricks. This is very strange anyway
because I use hard coded angular velocity unlike previous version. It's almost the same code than the cars. Sun any problem
with cars or all is "turning" fine ?


Turning of cars works beautifully Dan. No issues there. Just the Ummu turning is the problem. I don't think it is FPS
related. I can be in an empty area and have great FPS and still have issues.


"Sun Dog"

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #13 - 30 November 2009, 22:27:35
Okay Thanks Sun, I'll have a look. If cars work there is no reasons that I can't solve this for UMmu.

Cheers

Dan


Offline reekchaa

  • Hero Member
  • *****
  • Posts: 649
  • Country: United States us
  • Karma: 2
Reply #14 - 30 November 2009, 22:50:46

UCGO BUG-Feature

Bug with:

Arrow freighter Cargo Deployment

Short description:

Beam Light flashes on when SHIFT+C cargo deployed in external view

Severity

minor detail, but Very Pretty effect

Complete description

Trek transporter-like effect happens only when Beam Lights deployed

Reproduce bug

Load: Features/Mother ship - Arrow Freighter 18
Hit F1, mouse zoom & position close to see redbox cargo deploy area, hit SHIFT+C repeatedly until you see a "flash" of a
spot-light... coming from the '5X beam lights EL7' when verified by Dr.HealGood.  
One beam-light seems to deploy for 1 frame when cargo is released, signaling where this cargo is placed.
I actually LIKE this 'bug', would prefer it as a feature for ALL cargo releases as it seems to signify action, or even a
Trekish Transporter effect when cargo is moved.

Miscallenous

Everyone try this... does it not look REALLY nice when the EL7 is deployed with SHIFT+C in external view?  I would like to
see this effect for every cargo dropped/transferred, maybe even enhanced to more than 1 frame.  :)


~ the Reekchaa

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #15 - 30 November 2009, 22:56:23
Aah ah funny effect. I'll see if I have time for this one but as you say it's minor.

Personnaly I see clearly the light beam appear and not a "treck flash" maybe because I have 227 FPS

Cheers

Dan


Offline reekchaa

  • Hero Member
  • *****
  • Posts: 649
  • Country: United States us
  • Karma: 2
Reply #16 - 30 November 2009, 23:12:35

UCGO BUG
Bug with:

Arrow freighter - VC room

Short description:

visual hickup anim

Severity

minor detail

Reproduce bug

Load: Features/Mother ship - Arrow Freighter 18
Right from virtual cockpit, Hit CTRL+ALT+UP to watch move to view window.  Once at window, hit CTRL+ALT+LEFT and
see a hickup in the animation (repeated turn) before view returns to captains chair.  We also see a huge hole on the side
of the Arrow (both sides) before view returns to chair.  Changing views mid-anim to the window has no repeating hickup.

Miscallenous

no biggie. :)

~ the Reekchaa

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #17 - 30 November 2009, 23:20:00
Ooops I thought I locked it enough... Thanks !

For others: please don't try above if you want to keep the magic. Better not looking what's behind the camera if you
want to enjoy the movie :)


Dan


Offline Xyon

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 0
Reply #18 - 30 November 2009, 23:21:28
Quote
reekchaa wrote:

UCGO BUG
Bug with:

Arrow freighter - VC room

Short description:

visual hickup anim

Severity

minor detail

Reproduce bug

Load: Features/Mother ship - Arrow Freighter 18
Right from virtual cockpit, Hit CTRL+ALT+UP to watch move to view window.  Once at window, hit CTRL+ALT+LEFT and
see a hickup in the animation (repeated turn) before view returns to captains chair.  We also see a huge hole on the
side
of the Arrow (both sides) before view returns to chair.  Changing views mid-anim to the window has no repeating
hickup.

Miscallenous

no biggie. :)

I see it too. Perhaps a simple wall on the ends of the VC would fix that?

Quote
sunshine135 wrote:

UCGO BUG


Bug with:

Ummu

Short description:

Ummu has difficulty turning on lunar surface


Severity

moderate


Complete description

In the Mother ship- Arrow Freighter 18 scenario when you move the surface Ummu around, it is very difficult to get the
Ummu
to turn. Forward and Back motions are fine. Turning is overly difficult to the point of annoying and reduces playability.


Reproduce bug

Run the Mother ship- Arrow Freighter 18 scenario, focus on the Ummu and attempt left or right turns on the ground.
Granted,
movement on the moon should be a bit more cumbersome, but turning should not be that hard.


Miscallenous

I believe we have seen this before in previous Ummu versions and it needed a tweak to make it better. Perhaps you
used some
of that earlier code Dan?


UMMu turns fine for me.



Post Edited ( 11-30-09 23:23 )


Offline gattico

  • Sr. Member
  • ****
  • Posts: 337
  • Country: United States us
  • Karma: 15
Reply #19 - 30 November 2009, 23:35:08

UCGO BUG


Bug with:




Short description:

Orbiter appears to CTD on the "Construct a base by unpacking cargos" Scenario.


Severity

CTD


Complete description

(Orbiter appears to CTD on the "Construct a base by unpacking cargos" Scenario.)


Reproduce bug

(Load the "_UniversalCarsandCargos (UCGO) \ Features demonstrations - Learning \ Construct a base by unpacking
cargos.scn "  it should CTD)


Miscallenous

(If you have comments or something to add)



Post Edited ( 11-30-09 23:40 )


Offline Shadow Addict

  • Jr. Member
  • **
  • Posts: 21
  • Karma: 0
Reply #20 - 30 November 2009, 23:36:50
EDIT: Whoops, that wasn't a UCGO problem at all. I was getting blank MFDs cause I'm on my stupid laptop.



Post Edited ( 11-30-09 23:43 )


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #21 - 30 November 2009, 23:46:22
Quote
Shadow Addict a écrit:
These seems like a rather noticeable problem, so I'm assuming it's either been noticed before or is just a local
problem, but it seemed worthy of a bug report.

Edited also :)

I preffer that ;)

But again, don't hesitate to post or assume that a problem is minor, sometime it can hide a huge major problem.

Dan



Message modifié ( 30-11-2009 23:57 )


Offline Xyon

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 0
Reply #22 - 30 November 2009, 23:47:55
Quote
gattico wrote:

UCGO BUG


Bug with:




Short description:

Orbiter appears to CTD on the "Construct a base by unpacking cargos" Scenario.


Severity

CTD


Complete description

(Orbiter appears to CTD on the "Construct a base by unpacking cargos" Scenario.)


Reproduce bug

(Load the "_UniversalCarsandCargos (UCGO) \ Features demonstrations - Learning \ Construct a base by
unpacking
cargos.scn "  it should CTD)


Miscallenous

(If you have comments or something to add)

Loaded scenario fine and unpacked every box - no CTD here. What does orbiter.log say about it?


Offline reekchaa

  • Hero Member
  • *****
  • Posts: 649
  • Country: United States us
  • Karma: 2
Reply #23 - 30 November 2009, 23:53:16
Ummu has always turned fine for me too.  Difficult (slow) movement when holding heavy cargo (naturally) but turn is
always fine.  Interleaving (close proximity) with the cargoes, can make difficult selection (there seems to be a grapling
order, not just closest to center taking place).  Taking each of the Beam Lights of the 5 deployed and moving them, then
jumbling the cargo together with "U" can sometimes make me spawn additional EL7 Lights cargo boxes, which is fun.  
Anyone else?

~ the Reekchaa

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #24 - 30 November 2009, 23:53:42
Quote
gattico a écrit:
(Load the "_UniversalCarsandCargos (UCGO) \ Features demonstrations - Learning \ Construct a base by unpacking
cargos.scn "  it should CTD)

Unable to reproduce also, do you have a more precise procedure ? any other module than OrbiterSound activated ? any
manipulation you are doing ? Can you post the log as Xyon said ?

Much thanks

Dan



Message modifié ( 30-11-2009 23:55 )