See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: It's possible disable keyboard shortcuts in DGIV  (Read 843 times)

0 Members and 1 Guest are viewing this topic.

Offline Pietrogramma

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
05 December 2014, 15:06:51
Hallo everybody, I'm a new user of this forum, my name is Pietro and I'm italian.
I Use Orbiter 2010 for a short time and I am following a series of tutorial for a better understanding it.
In my training I use always DGIV di Dan and a few days ago I changed the file keymap.cfg to use a keyboard built specifically for orbiter (here the modified kaeyboard http://www.orbithangar.com/searchid.php?ID=6271 ) but this new keyboard don't work fine with DGIV.
some keys are in conflict with the default keys of DGIV.
Since I never use the keyboard shortcuts, it's possible delete (or modify) them in DGIV?
Thanks and bye bye


Offline sunshine135

  • Hero Member
  • *****
  • Posts: 546
  • Country: United States us
  • Karma: 1
  • I fly by the seat of my pants!
Reply #1 - 19 December 2014, 21:08:12
I am not familiar with the keyboard setup for this new Orbiter Keyboard, but I am betting that the remapped keyboard.cfg keys do not take into account the custom keyboard commands for the DGIV's flight computers. That is custom to Dan's Module for the DGIV. IMHO, I don't think there is a quick fix for this outside of using a standard keyboard with the typical key layout. Hence, the reason why the author asks you to save a copy of your original keyboard.cfg file. One other option would be to do a stare and compare of the new config to a list of keyboard commands to the DGIV's and reassign keys in the keyboard.cfg that conflict with Dan's custom keys.

Keys you expecially want to avoid are P, S, C, and E (Pro, Spec, Cancel, and Execute)

I hope you found this helpful.

"Sun Dog"