See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: Minor glitch noted in OrbiterSound 4.0  (Read 7820 times)

0 Members and 1 Guest are viewing this topic.

Offline David413

  • Full Member
  • ***
  • Posts: 129
  • Karma: 8
22 November 2012, 19:32:50
Forgive me if this has already been identified, but I've noticed what I consider more of an annoyance than an outright bug...When starting a scenario under either the inline graphics client, or D3D9, if the scenario begins in the external view, the framerate is very low.  Then, using F1 to go inside the cockpit and another F1 to go back outside, the framerate increases considerably and stays that way afterwards.  I have concluded that the Orbitersound module is causing this by disabling it and restarting the scenario, the framerate starts at the higher rate.

Just an observation...

Dave


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #1 - 22 November 2012, 23:54:17
I have seen such problem but only with the new P2 patch of martin.
This one should not be used yet as it's really an alpha and the callback
order are messed.

Else this was not reported at all for any of the OrbiterSound beta.
Can you confirm the version ?

Dan


Offline David413

  • Full Member
  • ***
  • Posts: 129
  • Karma: 8
Reply #2 - 23 November 2012, 00:18:21
The most recent release on Orbithangar is the version I'm using.  With Orbiter 2010 P1 (not a beta).


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #3 - 23 November 2012, 01:12:49
Can you post the OrbiterSound_log.txt ?


Offline David413

  • Full Member
  • ***
  • Posts: 129
  • Karma: 8
Reply #4 - 23 November 2012, 01:52:03
Sure, here it is.  FYI, I'm using a Windows 7 machine.

Dave

Code: [Select]
********************************************************
OrbiterSound 4.0 (3D) Build Nov 20 2012 01:00
********************************************************

Orbiter version: 100830
Advanced OrbiterSound settings: (Edit: 'Sound/cfg/Editable_Advanced_Configuration.cfg')
-------------------------------
Primary buffer 22050hz 16bits  (default 22050/16)
DopplerFactor 1.00 (default 1.00)
VaccumAttenuationFactor 1.00 (default 1.00)
SoundDistanceFactor 1.00 (default 1.00)
MaxSoundProcessPerSecond 60 (default 60)
MaxAnimCheckPerFrame 10 (default 10)
PlayWhenOrbiterInBackground false (default false)
WriteInLogAllLoadedSound false (default false)
-------------------------------

Orbiter directory:  C:\Orbiter Work\Orbiter2010P1TestingVelcro\
Listing planets winds and bases sounds:
  6 planet wind sound found
  4 bases sound found
Passed initModule - Ok
Passed ExitModule - Ok



Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #5 - 23 November 2012, 01:57:11
Okay, I just tested I cannot confirm this one. I didn't had any report on framerate also.

Did you checked with "01- Per-vessel sound environnment" ? it start in external view, no fps change.
If not try some scenarios and check who cause problem and who don't.


Offline David413

  • Full Member
  • ***
  • Posts: 129
  • Karma: 8
Reply #6 - 23 November 2012, 02:26:37
Tried the scenario you requested, initial framerate is 16 FPS on my machine, went to internal view, framerate increased to 34 fps, then when I went back to external, stayed at 33 to 34 fps.  

Dave


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #7 - 23 November 2012, 03:46:52
Wow, that is very low in anyway...

I have 105 FPS in both case with a 4 years old PC (XP)
(I lock it usually to 60FPS)

Given the very low framerate I would say there can be multiple causes possible
it might be in OrbiterSound but it might be simply a bottleneck somewhere
that is pushed at fault by a slight change. (sound load etc etc) in OS.

Unless there is other report of this I'll let it drop for yet sorry.

Dan


Offline cslevine

  • Legend
  • ******
  • Posts: 3621
  • Karma: 17
Reply #8 - 23 November 2012, 21:09:27
348 Fps confirmed at a first launch and without do anything with Directx 9 client.

often, some audio can interact and maybe conflict with some todays graphic cards, because some manufacturer had the good idea to mess up beetween HD Audio and graphic drivers.
That's when installing the DVD of GPU drivers, "HD Audio" or so on is listed as options to install... why not.
One day we'll have modem options with a simple clockwatch, or some other funny mixings, that's so fun :)

to resume be short :
so try to reinstall or upgrade graphic drivers could maybe strangly fix the FPS problem with new 3D audio calls.



Offline Cras

  • Full Member
  • ***
  • Posts: 101
  • Country: United States us
  • Karma: 3
Reply #9 - 01 December 2012, 22:04:39
I dont think I am seeing a framerate hit......either way my framerate is nowhere near that low that one would be too noticeable.  But I will keep an eye on the fps on scenario launches to see if I get any sort of performance hit


Orbiter | SSMS2007 | FSX

Offline andrebrait

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Reply #10 - 13 December 2012, 22:13:05
My framerate is pretty OK, but since I installed Sound 4.0, my machine has been randomly locking up (like I had pressend Winkey+L). With the old sound add-on I never had this problem. I'll confirm with a new Orbiter installation.


Offline Cras

  • Full Member
  • ***
  • Posts: 101
  • Country: United States us
  • Karma: 3
Reply #11 - 14 December 2012, 07:28:02
I have just seen this bug flying SF. 4.8

The frame rate was low, like 40 something, the OBSS (Which was grappled and positioned off to the side of the orbiter), did not appear immediately.

After cycling views, my frame rate jumped back up to 400+ something, back to around where I would expect it to be.


Orbiter | SSMS2007 | FSX

Offline Michaeljohn

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Reply #12 - 25 June 2013, 08:19:36
back to around where I would expect it to be.




______________________________________________________________
WOW Gold|Wow Gold Kaufen|Diablo 3 Gold|Guild Wars 2 Gold


« Last Edit: 25 June 2013, 08:19:36 by Michaeljohn »
john Michael