See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: [Résolu] Pb VC2005 C++  (Read 2322 times)

0 Members and 1 Guest are viewing this topic.

Offline brainstorm

  • Legend
  • ******
  • Posts: 2694
  • Karma: 0
30 October 2008, 07:51:01
Salut ! Bon, j'ai tout installé comme il faut, et pour l'exemple du shuttlepb, j'ai ça :

Quote
------ Début de la génération : Projet : ShuttlePB, Configuration : Debug Win32 ------
Compilation en cours...
cl : Ligne de commande warning D9028 : échec de la régénération minimale, passage à la génération normale
ShuttlePB.cpp
d:\orbitersdk\samples\shuttlepb\shuttlepb.cpp : fatal error C1902: incompatibilité de gestionnaire de bases de
données du programme ; veuillez vérifier votre installation
Le journal de génération a été enregistré à
l'emplacement "file://d:\Orbitersdk\samples\ShuttlePB\Debug\BuildLog.htm"
ShuttlePB - 1 erreur(s), 1 avertissement(s)
========== Génération : 0 a réussi, 1 a échoué, 0 mis à jour, 0 a été ignoré ==========

Là, je coule ;) Une idée pleeeaaase ? ;)



Message modifié ( 30-10-2008 19:37 )


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15191
  • Karma: 208
  • Hein, quoi !?
    • FsPassengers
Reply #1 - 30 October 2008, 09:44:19
Le plus simple c'est de googler avec les no d'erreurs "D9028" et "C1902"
http://msdn.microsoft.com/fr-fr/library/8y7hea02.aspx

J'ai jamais eu celle la mais a priori ca sent plutôt la mauvaise installation, path, version de fichier etc etc...

Je chercherais sur d'autres forum pour trouver des users qui ont eu la même erreur... (et donnent des solutions)

Dan



Message modifié ( 30-10-2008 09:46 )


Offline no matter

  • Legend
  • ******
  • Posts: 2826
  • Karma: 1
Reply #2 - 30 October 2008, 14:31:05
Mister Microsoft dit :
"Le fichier de projet .idb est endommagé. Supprimez le fichier et régénérez-le."

Voir ici: http://msdn.microsoft.com/fr-fr/library/xyac57k7(VS.80).aspx


------------

no matter.

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15191
  • Karma: 208
  • Hein, quoi !?
    • FsPassengers
Reply #3 - 30 October 2008, 15:19:13
Mouais mais je le sens pas la... un clean rebuilt aurais du rêgler le prob, comme il vient de faire l'install je dirais plutôt

C1902:
"Assurez-vous que les versions correspondantes de mspdbsrv.exe, mspdbcore.dll et mspdbXX.dll sont installées sur
votre système. Assurez-vous que des versions incompatibles n'ont pas été copiées vers le répertoire qui contient le
compilateur et les outils LINK pour votre plateforme cible. Par exemple, vous auriez pu copier les fichiers et ainsi
appeler le compilateur ou l'outil LINK à partir de l'invite de commandes sans définir la variable d'environnement
PATH en conséquence
."

Faut voir les forums: "C1902" "installation" "path"
http://www.google.fr/search?hl=fr&rlz=1T4GGLJ_frFR175FR175&q=%2BC1902+installation+path&meta=

T'a pas un bat a lancer pour faire l'enregistrement des paths ?

Dan


Offline brainstorm

  • Legend
  • ******
  • Posts: 2694
  • Karma: 0
Reply #4 - 30 October 2008, 19:37:23
Alors, j'ai tout réinstallé (changer les répertoires, ça allait pas trop je pense ...)
Pb réglé ;) Merci encore pour vos infos ;)



Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15191
  • Karma: 208
  • Hein, quoi !?
    • FsPassengers
Reply #5 - 31 October 2008, 01:15:17
A la bonne heure !

Et bonne chance avec le... euh... reste.... ;)

Dan


Offline no matter

  • Legend
  • ******
  • Posts: 2826
  • Karma: 1
Reply #6 - 31 October 2008, 15:18:57
Cool, plus qu'à faire confiance à F7 ;)

Quote
Mouais mais je le sens pas la... un clean rebuilt aurais du rêgler le prob, comme il vient de faire l'install je dirais
plutôt
Mince, je n'avais pas vu cette seconde erreur.


« Last Edit: 31 October 2008, 18:05:24 by no matter »
------------

no matter.

Offline brainstorm

  • Legend
  • ******
  • Posts: 2694
  • Karma: 0
Reply #7 - 31 October 2008, 18:05:24
En fait, j'ai encore qqs soucis, mais bon, je pense que c'est du paramétrage ce coup la ... ;)


« Last Edit: 31 October 2008, 18:05:24 by brainstorm »