See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: [Beta test] OrbiterSound 4.0 avec son 3D  (Read 33747 times)

0 Members and 1 Guest are viewing this topic.

Online DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15116
  • Karma: 193
  • Hein, quoi !?
    • FsPassengers
Reply #300 - 24 October 2012, 23:42:16
Quote
SolarLiner a écrit:
Donc j'en ai sacrifié un peu mais je ne peix tomber en dessous de 22500...

Mhhh... pour en avoir beaucoup tripoté je suis pas sur du tout qu'au milieu du bordel du décollage on entende une différence énorme entre du 22khz et du 16khz. On est surtout dans la dynamique des basse fréquences pour "booster" un décollage et les voix passent très bien à 16k.


Offline SolarLiner

  • Global Moderator
  • Legend
  • *****
  • Posts: 2769
  • Country: France fr
  • Karma: 55
  • a été remercié par Le Créateur
Reply #301 - 25 October 2012, 00:38:38
Arf, difficile d'expliquer sans "spolier" le tout... Tant pis : C'est à cause de l'effet "pop-corn" très présent dans cette version, et l'aigu dans cette partie là renforce l'intensité de l'effet. Et déjà le 22500 coupe de cet aigu, délaissant une part de puissance sonore avec... Tant pis je couperai avant !



Offline cslevine

  • Legend
  • ******
  • Posts: 3607
  • Karma: 12
Reply #302 - 25 October 2012, 00:47:06
Quote
Yep, comme les users font parfois n'importe quoi y compris charger des wav de 20mb au risque de planter tout le reste j'ai mis cette limite.

oui et penser du coup à documenter ces petites limites :
- les wave doivent peser moins de 9 Mo pour être pris en compte
- les bases scannées par Orbitersound le seront à concourrence des 200 premières dans l'ordre alphabétique


Concernant le son de la navette pour Solarliner, peut être une autre solution possible :
1. un countdown -10 ou même -20
2. un nouveau son nommé Aux-trust est utilisé pour faire sonner les SRB. Peut être utiliser celui là,.... Ah mais non ( je réfléchis tout haut en fait ) car c'est bien un son extérieur, et il décroit au fil de l'ascension.

ou bien il existe aussi les dialogues radio, avec Sequential Editor, mais là je ne sais pas si on peut lancer une séquence radio à un moment précis
... mais du 16 Khz effectivement va très bien aller, et ainsi jusqu'au "Proosch !!...  booster report good separation"


ensuite, et en attendant peut être une nouvealle mouture d'Atlantis par Dr Martin apportant plus d'animations audio (séparation boosters, séparation réservoir )
avec les nouveaux switchs animés, ceux du panneau arrière, il est sans doute possible d'attribuer un son différent à chacun des boutons, et donc se la donner un peu.



Offline SolarLiner

  • Global Moderator
  • Legend
  • *****
  • Posts: 2769
  • Country: France fr
  • Karma: 55
  • a été remercié par Le Créateur
Reply #303 - 26 October 2012, 14:52:48
Youpi !!!
Avec une ré-exportation (sans doute qu'il y avait eu un bug précédemment), j'ai réussi à descendre le poids du fichier à 6 Mo ! ET je me suis rendu compte de OS améliorait les aigus, donc en fait c'est carrément suffisant ... Donc version Atlantis avec tout les "calls" jusqu'aux SRB Sep, et une autre pour la Shuttle Fleet sans ces call ...



Offline cslevine

  • Legend
  • ******
  • Posts: 3607
  • Karma: 12
Reply #304 - 26 October 2012, 22:21:59
Très bien !


:hot:  :hot:  :hot:

Appel, il faudrait plus de participants pour la béta-tests de la nouvelle version d'Orbitersound, la 4.0 qui doit sortir un prochain Mardi ! Mais c'est iun peu à vous de choisir quel mardi vous voulez faire l'expérience saisissante des nouveaux sons spatialiséss en 3D...
....ou même simplement en stéréo : nul besoin d'avoir la config audio de l'IRCAM  !!!
 2 enceintes stéréos et vous serez déjà bluffés.

pour ça envoyez un MP à Dan, il vous en sera très reconnaissant, même si c'est simplement un test vite fait, et un petit retour pour dire si UN petit truc déconne.

il se décarcasse à donf, là. Bientôt les vacances de la Toussaint, profitez en !



Offline Jim Lovell

  • Global Moderator
  • Legend
  • *****
  • Posts: 1485
  • Country: Belgium be
  • Karma: 22
    • Mon site
Reply #305 - 27 October 2012, 12:25:08
J'aimerais m'impliquer dans le test, découvrir cette nouvelle version.. Malheureusement je manque cruellement de temps pour le tester de fond en comble ou reporter des bugs dans des situations très précises... :(
J'attendrai donc la version finale ;)


Jim Love:love:LL
C'est en se plantant que l'on construit ses racines....


ConneXion

Offline cslevine

  • Legend
  • ******
  • Posts: 3607
  • Karma: 12
Reply #306 - 05 November 2012, 23:06:21
au fait je voulais dire, pour Earth_default2.wav

c'est vrai il est carrément génial ce plugin VST  ( dont je n'ai plus le nom en tête ce soir )
mais quels beaux sons !  On peut même aussi faire la pluie avec (ou avec un plugin voisin du même éditeur) et aller de la pluie fine jusqu'à la mousson, de la fine brise jusqu'à la catherinade de Sandy,
ça rend super bien !



Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 6189
  • Country: France fr
  • Karma: 338
  • Plus on rate, plus on a de chances de réussir !..
Reply #307 - 07 November 2012, 22:54:04
Je suis inquiet...

Voilà mon histoire:
Je fais une sauvegarde "en mirroir" de mon Tintin (entres autres sauvegardes!!!) et je me suis dit : "testons mes sons avec le nouveau OrbiterSound"

1) problème pour linstall: y veut pas :trucdeouf: pasque y me dit "pas Orbiter 2006, je veux Orbiter 2010!"
:wonder: pourtant c'est bien 2010P1 :wonder:
:) ah j'ai trouvé! Il a pas trouvé "Obiter_ng..exe":badsmile: 'fectivement, je l'avais enlevé car je ne m'en sert pas pour mes test "Tintin"...
... mais je signale, ça peut servir...

2) PAR CONTRE :rant:
Sur tous mes "vaisseaux" seule la fusée fait du bruit (bizarre, d'ailleurs...), le reste est silencieux ...(hélicoptère, char, tours, personnages...)
Donc je suis inquiet (bis)  :)

Est-ce parceque ce sont tous des objets "Spacecraft3 de Vinka" ?
Est-ce que quelqu'un a déjà testé un engin Spacecraft ?
(je n'ai pas le temps de poursuivre mes tests)

Je met le fichier log:

Code: [Select]
********************************************************
OrbiterSound 4.0 build Oct 22 2012 18:03:48  Log Started
********************************************************

Advanced OrbiterSound settings: (Edit: 'Sound/cfg/Editable_Advanced_Configuration.cfg')
-------------------------------
Primary buffer 22050hz 16bits  (default 22050/16)
DopplerFactor 1.00 (default 1.00)
VaccumAttenuationFactor 1.00 (default 1.00)
SoundDistanceFactor 1.00 (default 1.00)
MaxSoundProcessPerSecond 60 (default 60)
MaxAnimCheckPerFrame 10 (default 10)
PlayWhenOrbiterInBackground false (default false)
WriteInLogAllLoadedSound false (default false)
-------------------------------

Orbiter directory:  E:\FS\_Pack tintin (en cours)\_Orbiter test\
Listing planets winds and bases sounds:
  6 planet wind sound found
  4 bases sound found
Passed initModule - Ok
Vessel Fusee_lunaire requested an ID, returned= 0 OK
Vessel Tournesol requested an ID, returned= 1 OK
Vessel Haddock requested an ID, returned= 2 OK
Vessel Tintin requested an ID, returned= 3 OK
Vessel Milou requested an ID, returned= 4 OK
Vessel Wolff requested an ID, returned= 5 OK
Vessel Dupond requested an ID, returned= 6 OK
Vessel Dupont requested an ID, returned= 7 OK
Vessel Tour1 requested an ID, returned= 8 OK
Vessel Tour2 requested an ID, returned= 9 OK
Vessel Tour3 requested an ID, returned= 10 OK
Vessel Jeep requested an ID, returned= 11 OK
Vessel Char requested an ID, returned= 12 OK
Vessel Helicopter requested an ID, returned= 13 OK
Vessel Sortie_lunaire requested an ID, returned= 14 OK
Attempting RenderViewport initialisation...
Attempting GetStartValue initialisation...
Passed GetStartValue - Ok
Initialising directsound...
   Sound hardware capabilities: Driver is certified.
   Maximum hardware mixing buffers: 17.
   Maximum hardware 3D buffers: 16.
   Speaker configuration: stereo with wide (arc of 20 deg.) geometry  
   Attempt to create Primary buffer: 22050hz 16bits 3d: yes
   3D primary buffer initialised OK
directsound initialised - OK
Passed RenderViewport - Ok
Attempting Mp3 initialisation...
M3U list found attempting loading it.
MP3 found in playlist =  1
Mp3 initialised - Ok
Focus changed attempting to load vessel wave
Info: No sound config found for class:  Spacecraft3B
Focus changed load vessel wave - OK
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound/Vessel/none  DX Code: E_FAIL
attempting focus change...
Attempting GetStartValue initialisation...
Passed GetStartValue - Ok
Focus changed attempting to load vessel wave
Info: No sound config found for class:  Spacecraft3B
Focus changed load vessel wave - OK
focus changed - Ok
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Generique2.wav  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Helico.wav  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Helico2.wav  DX Code: E_FAIL
Info: Failed loading stereo RCS wav for 3d RCS positionning, reverting to 2d RCS (normal)
FAILED: FindResource  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave->unable to find wave: Sound\Vessel\Tintin\Helico2.wav  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave->unable to find wave: Sound\Vessel\Tintin\Helico.wav  DX Code: E_FAIL
attempting focus change...
Attempting GetStartValue initialisation...
Passed GetStartValue - Ok
Focus changed attempting to load vessel wave
Info: No sound config found for class:  Spacecraft3B
Focus changed load vessel wave - OK
focus changed - Ok
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Char.wav  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\none  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Freins.wav  DX Code: E_FAIL
Info: Failed loading stereo RCS wav for 3d RCS positionning, reverting to 2d RCS (normal)
FAILED: FindResource  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave->unable to find wave: Sound\Vessel\Tintin\Freins.wav  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave->unable to find wave: Sound\Vessel\none  DX Code: E_FAIL
Attempting to close viewport...
Attempting to kill DirectSound...
Nbr of waves loaded during simulation: 109
Max nbr of waves in memory in same time: 44
Nbr of waves failed to load: 15
Total of waves not unloaded at exit: 0
DirectSound killed - OK
Passed CloseRenderViewport - Ok
Exited to Orbiter Launchpad - OK

Vessel Fusee_lunaire requested an ID, returned= 0 OK
Vessel Tournesol requested an ID, returned= 1 OK
Vessel Haddock requested an ID, returned= 2 OK
Vessel Tintin requested an ID, returned= 3 OK
Vessel Milou requested an ID, returned= 4 OK
Vessel Wolff requested an ID, returned= 5 OK
Vessel Dupond requested an ID, returned= 6 OK
Vessel Dupont requested an ID, returned= 7 OK
Vessel Tour1 requested an ID, returned= 8 OK
Vessel Tour2 requested an ID, returned= 9 OK
Vessel Tour3 requested an ID, returned= 10 OK
Vessel Jeep requested an ID, returned= 11 OK
Vessel Char requested an ID, returned= 12 OK
Vessel Helicopter requested an ID, returned= 13 OK
Vessel Sortie_lunaire requested an ID, returned= 14 OK
Attempting RenderViewport initialisation...
Attempting GetStartValue initialisation...
Passed GetStartValue - Ok
Initialising directsound...
   Sound hardware capabilities: Driver is certified.
   Maximum hardware mixing buffers: 17.
   Maximum hardware 3D buffers: 16.
   Speaker configuration: stereo with wide (arc of 20 deg.) geometry  
   Attempt to create Primary buffer: 22050hz 16bits 3d: yes
   3D primary buffer initialised OK
directsound initialised - OK
Passed RenderViewport - Ok
Attempting Mp3 initialisation...
M3U list found attempting loading it.
MP3 found in playlist =  1
Mp3 initialised - Ok
Focus changed attempting to load vessel wave
Info: No sound config found for class:  Spacecraft3B
Focus changed load vessel wave - OK
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound/Vessel/none  DX Code: E_FAIL
attempting focus change...
Attempting GetStartValue initialisation...
Passed GetStartValue - Ok
Focus changed attempting to load vessel wave
Info: No sound config found for class:  Spacecraft3B
Focus changed load vessel wave - OK
focus changed - Ok
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Generique2.wav  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Helico.wav  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Helico2.wav  DX Code: E_FAIL
Info: Failed loading stereo RCS wav for 3d RCS positionning, reverting to 2d RCS (normal)
FAILED: FindResource  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave->unable to find wave: Sound\Vessel\Tintin\Helico2.wav  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
FAILED: FindResource  DX Code: E_FAIL
LoadWave->unable to find wave: Sound\Vessel\Tintin\Helico.wav  DX Code: E_FAIL
Attempting to close viewport...
Attempting to kill DirectSound...
Nbr of waves loaded during simulation: 74
Max nbr of waves in memory in same time: 42
Nbr of waves failed to load: 8
Total of waves not unloaded at exit: 0
DirectSound killed - OK
Passed CloseRenderViewport - Ok
Exited to Orbiter Launchpad - OK

Vessel Fusee_lunaire requested an ID, returned= 0 OK
Vessel Tournesol requested an ID, returned= 1 OK
Vessel Haddock requested an ID, returned= 2 OK
Vessel Tintin requested an ID, returned= 3 OK
Vessel Milou requested an ID, returned= 4 OK
Vessel Wolff requested an ID, returned= 5 OK
Vessel Dupond requested an ID, returned= 6 OK
Vessel Dupont requested an ID, returned= 7 OK
Vessel Tour1 requested an ID, returned= 8 OK
Vessel Tour2 requested an ID, returned= 9 OK
Vessel Tour3 requested an ID, returned= 10 OK
Vessel Jeep requested an ID, returned= 11 OK
Vessel Char requested an ID, returned= 12 OK
Vessel Helicopter requested an ID, returned= 13 OK
Vessel Sortie_lun



Message modifié ( 08-11-2012 12:23 )

Mes add-ons sont là !

Online DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15116
  • Karma: 193
  • Hein, quoi !?
    • FsPassengers
Reply #308 - 08 November 2012, 04:53:12
Impec, quelqu'un qui test spacecraft !!! :top:

-Ils existent ces fichiers ?

Quote
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Generique2.wav  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Helico.wav  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Helico2.wav  DX Code: E_FAIL
LoadWave->unable to find wave: Sound\Vessel\Tintin\Helico.wav  DX Code: E_FAIL

-Ça marchait avec OrbiterSound 3.5 ou c'est une nouvelle [copie/install] d'Orbiter ?
-Si doute essaie d'installer 3.5 et teste avec cette install. Normalement ça doit marcher avec les deux.
Si ça marche avec aucun c'est ton install/code.

Dan



Message modifié ( 08-11-2012 04:56 )


Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 6189
  • Country: France fr
  • Karma: 338
  • Plus on rate, plus on a de chances de réussir !..
Reply #309 - 08 November 2012, 12:08:19
Quote
DanSteph a écrit:
-Ils existent ces fichiers ?
Quote
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Generique2.wav  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Helico.wav  DX Code: E_FAIL
LoadWave3D->unable to load 3D wave: Sound\Vessel\Tintin\Helico2.wav  DX Code: E_FAIL
LoadWave->unable to find wave: Sound\Vessel\Tintin\Helico.wav  DX Code: E_FAIL
Ben oui, je pense... je vérifierai tout de même..

Quote
DanSteph a écrit:
-Ça marchait avec OrbiterSound 3.5 ou c'est une nouvelle [copie/install] d'Orbiter ?
ça marche très bien avec 3.5. J'ai installé "pardessus" la v4...

Quote
DanSteph a écrit:
-Si doute essaie d'installer 3.5 et teste avec cette install. Normalement ça doit marcher avec les deux.
Si ça marche avec aucun c'est ton install/code.
"install/code" :wonder: c'est quoi?
Je vais essayer (mais je ne pense pas avoir le temps avant ce week-end) sur une install "propre" et nouvelle, toujours avec mon (futur) add-on, et aussi avec d'autres Spacecraft.
Je te dirais...

A+



Message modifié ( 08-11-2012 12:24 )

Mes add-ons sont là !

Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 6189
  • Country: France fr
  • Karma: 338
  • Plus on rate, plus on a de chances de réussir !..
Reply #310 - 08 November 2012, 22:21:02
Bon j'ai re-fait un test...

Autre ordinateur.
Nouvel install d'Orbiter et install Orbitersound4 (beta_22Oct2012). je laisse tout par défaut.
et... ça marche !!!

Faut donc que je trouve pourquoi ça ne marche pas sur l'autre ordi... :badsmile: affaire à suivre...

MAIS :trucdeouf: y tout de même un problème:
 - Le son des "main" a changé (fusée, char, jeep...) mais ça va...
 - Par contre, mon hélicoptère Syldave (son "Hoover") a maintenant un son plus proche de celui d'un projecteur de film Super8 que d'un hélico...
:wonder: est-ce bien normal ???

Toujours pareil: peu de temps pour tester, dès que j'ai le temps je poursuis mes investigations.
Mais ce qui est sûr, c'est que le son des "main" et hoover" est changé. Pas celui des RCS...


« Last Edit: 08 November 2012, 22:21:02 by jacquesmomo »
Mes add-ons sont là !