See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: Help Compiling Addons with Orbiter Sound 5  (Read 1740 times)

0 Members and 1 Guest are viewing this topic.

Offline TomG117

  • Newbie
  • *
  • Posts: 1
  • Karma: 1
16 March 2022, 12:18:39
Hi All,

I had a question about compiling an addon with orbiter sound 5 for orbiter 2016.

I am trying to develop a vessel which uses Orbiter Sound 5, but I have been going around in circles for days on this. I am using both Visual Studio 2010 and 2022 and can't get this right. I get strange errors such as "mismatch detected for '_MSC_VER': value '1900' doesn't match value '1600'"

I have never had any issues adding orbiter sound for previous versions of orbiter sound to my addons, and I thought surely someone else may have encountered this problem. Is there something simple I am missing? I cannot find any information about this in Dan's SDK documentation.

Alternativeley, would anyone know in what version of Visual Studio Dan developed Orbiter Sound 5?

I would be greatful for any advice!

Thank you all,

Tom


Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 6832
  • Country: France fr
  • Karma: 479
  • Plus on rate, plus on a de chances de réussir !..
Reply #1 - 16 March 2022, 12:34:21
Hi Tom

Welcome  :beer:

I get strange errors such as "mismatch detected for '_MSC_VER': value '1900' doesn't match value '1600'"
I think it is Visual Studio 2010 but I'm not sure...
What I know is that he made a tutorial with VS 2005 here: http:// orbiter.dansteph.com/forum/index.php?topic=6334.msg95341#msg95341

Also, BrianJ (on the English forum) uses VS2010

so I can't answer your question...

Alternativeley, would anyone know in what version of Visual Studio Dan developed Orbiter Sound 5?
And  unfortunately Dan has disappeared from radar screens...  :(
And so, not knowing how to compile dlls yet, I can't tell you more... Sorry....

Mes add-ons sont là !

Offline Max-Q

  • Newbie
  • *
  • Posts: 2
  • Karma: 4
Reply #2 - 21 March 2022, 18:34:29
I had the same issue.  IIRC, I added "vcruntime.lib" to my linker Additional Dependencies.
There may be other stuff I did too, that project was a while ago.  Also always helpful to Google any errors you get.

FYI, I am using VS2019.

In God we trust, all others bring data.

Offline larebulor9

  • Newbie
  • *
  • Posts: 1
  • Country: United States us
  • Karma: 0
Reply #3 - 17 June 2022, 12:15:30
interesting information


Offline SpaceTravel

  • Vsphère=4/3πr3
  • Jr. Member
  • **
  • Posts: 41
  • Country: France fr
  • Karma: 15
  • Têtu et alors ?
    • Soundcloud
Reply #4 - 17 June 2022, 12:37:37
interesting information

Welcome "larebulor9" and hello America.   :beer:
Can you elaborate a bit more on your point ? something like "subject verb complement"   :lol:

 :merci:


« Last Edit: 30 June 2022, 15:17:01 by SpaceTravel »
Génie préféré: Eratosthène
Film comique préféré: Mars Attaks  "Professeur, de quoi sommes nous sûr pour l’instant ?" (04’46 sec) 
Discipline préféré: La paléontologie
Remarque: La pesanteur ? Nous avons maintenant besoin de g 9.81 pour évoluer puissamment vers d’autres planètes, ou bien ?