See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: On-Screen controls disappear in Orbiter2016  (Read 278 times)

0 Members and 1 Guest are viewing this topic.

Offline rico1

  • Newbie
  • *
  • Posts: 2
  • Karma: 1
18 February 2021, 01:09:06
Hi - I'm re-acquainting myself with Orbiter after a LONG absence.  I am running on a MacBook Pro using Manjaro Linux 5-10 and PlayOnLinux.  I have installed the D3D9 Client, Orbiter Sound 5.0, the Delta-Glider 4, the DirectX Jun2010 runtimes and Visual Studio 2015.

The Launcher appears and seems to work to allow selection of modules, video, etc, and the program launches.

My problem is that the onscreen controls appear, and are clickable, but the pop-down windows (eg for Camera, but all which have pop-down windows do the same) appear, then as soon as I move the mouse towards it, it disappears completely.  And cannot be found.  So I cannot interact with the programme at all.  Once the drop-down window disappears, clicking on the 'parent' window (eg Ship, Camera, Function) has no effect at all.   I can Pause, or Quit.

And when I Quit, the programme (or Wine, don't know which) crashes, instead of reverting to the Launcher.

Is this / are these [a] known / obvious problem(s)?   

I could have got something wrong in the installation,but have no idea where to start looking.   Many thanks for any suggestions.


Offline oppnalank

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Reply #1 - 05 March 2021, 15:56:23
Sorry to say that I have the same problem on my Macbook pro, but without any good solution... if there is anyone out there that can help that would be amazing!  :wor: :love:


Offline rico1

  • Newbie
  • *
  • Posts: 2
  • Karma: 1
Reply #2 - 05 March 2021, 18:19:45
Hello

I have indeed found a couple of workarounds - the second only yesterday!

The 'disappearing buttons' stop disappearing when I run Orbiter in a window instead of full-screen.  I used 1920x1200 which allows the main cockpit control panel to fill the window from side to side.  I used the option to have window plus taskbar.  That way I can also arrange a couple of external MFDs on my desktop as well.

I don't know how you are running Orbiter - under Wine, PlayOnMac, Winebottler or via Parallels or VMWare.  My solution is actually operating under Manjaro Linux because there is no Wine support on Catalina atm.   Accordingly I don't know for sure if this solution works on anything other than PlayOnMac (and that's an assumption based on the similarity with PlayOnLinux).

Anyway, with this option I can at least get into orbit!

The second point is about saving.  I found the solution to this on the Orbiter forum.  The solution is to do a Quicksave - either by Ctrl-S or from the top taskbar - before exiting.  This doesn't stop the crash, but it preserves the 'exit' state under Scenarios > Quicksaves.  So you can at least return to a ship in orbit without having to re-enter all the options and do the ascent again.

One you have the sim working, you may find that various other adjustments are necessary.  One major one for me, running on PlayOnLinux, was to use Wine 4.1 instead of system Wine.  Otherwise, I had graphics in the MFDs but no text.  If you are not running under some flavour of Wine, you may not need this option.

Hope this works for you.  The Docs folder under Orbiter is worth saving to Desktop, and the Orbiter User Manual is a mine of useful information.


Post Merge: 05 March 2021, 18:25:12
Just to add that if this works for you, I may mark the thread as potentially Solved - I see it has attracted 222 views.

Please let me know!   :turning: