See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: Pas coopératif NASSP version 8.  (Read 633 times)

0 Members and 1 Guest are viewing this topic.

Offline nulentout

  • Legend
  • ******
  • Posts: 3340
  • Country: France fr
  • Karma: 233
24 November 2020, 09:46:19
Bonjour les amis,
Toujours dans la rédaction de mes fiches sur l’installation d’Orbiter 2016, je rencontre un mur avec  NASSP.
Pas moyen de le faire fonctionner correctement, que ce soit en version 7 ou en version 8.  :wall:

Pour installer NASSP j'utilise une version "propre" d'Orbiter, c'est à dire un Noyau sans autres compléments que les indispensables comme le son, IMFD, LTMFD. D3D9 est installé ainsi que vcredist_x86.exe ainsi que  DirectX.

Considérons la version 8 :
Quand j'ai installé NASSPv8, le lancement réclame MSVCP140.dll que j’installe.
Il provoque ensuite le message d’alerte :
"Api-ms-win-crt-runtime-l1-1-0.dll manquant."
Je tente de loger ce fichier dans Modules ou dans Modules_Server. Dans les deux cas, le texte d’alerte devient :
"Le point d’entrée de procédure ucrtbase.abort est introuvable dans la bibliothèque de liens dynamiques Api-ms-win-crt-runtime-l1-1-0.dll"
•   Tenter de créer un lien symbolique ne change rien.
•   Placer le module dans Windows\System32 même punition.
Tenter d’activer une scène engendre un CTD.

Bref, impossible de faire fonctionner ce scongregneugneu de NASSP.  :rant:

Kékun aurait une idée … même saugrenue ?  :wonder:

Amicalement : Nulentout.

La sagesse est un trésor ... tellement bien caché.

Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 6487
  • Country: France fr
  • Karma: 391
  • Plus on rate, plus on a de chances de réussir !..
Reply #1 - 24 November 2020, 10:10:34
Décidemment tu as de gros problèmes avec Orbiter 2016....  :trucdeouf:

Alors je ne peux pas t'aider : j'ai bien NASSP7 installé, mais sur un Orbiter 2010.

La version 8 faut pas l'installer sur la "beta" d'Orbiter ???  :wonder:

Je pense que Pappy2 (qui est toujours de bon conseil) pourras t'aider.
Moi, je suis incompétent avec Nassp... Normal, je préfère AMSO....  :love:

Mes add-ons sont là !

Offline Gingin

  • Sr. Member
  • ****
  • Posts: 424
  • Country: France fr
  • Karma: 78
Reply #2 - 24 November 2020, 15:20:09
Hello, je ne sais pas si tu as vu sur le forum Orbiter la sous partie NASSP pour l'installation de Nassp 8

https://www.orbiter-forum.com/threads/nassp-8-installation-guide.36801/

En effet, il est recommandé d'utiliser la version Beta d'Orbiter 2016.

Visez les étoiles , au pire vous tomberez sur la Lune.

Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 6487
  • Country: France fr
  • Karma: 391
  • Plus on rate, plus on a de chances de réussir !..
Reply #3 - 24 November 2020, 17:03:01
En effet, il est recommandé d'utiliser la version Beta d'Orbiter 2016.
Ah ! Il me semblais bien....  yé fouzille ?   :expliquechapo:

Mes add-ons sont là !

Offline Pappy2

  • Legend
  • ******
  • Posts: 6752
  • Country: France fr
  • Karma: 312
Reply #4 - 24 November 2020, 22:33:48
Bonsoir les amis,  :wor:
A ben ça léfouzziye facile par là  :trucdeouf:  :expliquechapo:

Pour l'installation de NASSP 7.0 c'est UNIQUEMENT avec Orbiter 2010p1 et c'est par là:
http://nassp.sourceforge.net/wiki/Installation

NASSP 7.0 est la DERNIERE version stable développé, il n'y en aura pas d'autre, pour Orbiter2010p1.

 :bug:

Concernant la dernière version bêta d'Orbiter NASSP 8.0 elle n'est pas compatible avec Orbiter 2010p1 et est pour le moment uniquement compatible avec la dernière version bêta d'Orbiter 2016, qui comprend une correction cruciale de la physique des vaisseaux spatiaux ancrés qui n'est pas dans la version de sortie.

Pour l'installation et bien c'est par ici:
https://www.orbiter-forum.com/threads/nassp-8-installation-guide.36801/

Attention de bien suivre la procédure à la lettre  :worry:
Dans les post en dessous j'ai poser quelques questions sur la façon de l'installer, et avec ces précisions tout devrait bien se passer.  :sage:

NASSP 8 et en constant développement et les mises à jours arrivent quasiment tout les 3 / 4 jours, voir tous les jours.

@+ Pappy2_________
Citation célèbre:
Lorsque la trajectoire Képlérienne du mobile coupe la sphère du géoïde de l'astre de capture, ce n'est généralement pas très bon pour l'avenir du beau vaisseau et de son équipage
"Nulentout"

Offline nulentout

  • Legend
  • ******
  • Posts: 3340
  • Country: France fr
  • Karma: 233
Reply #5 - 25 November 2020, 10:35:58
OK les copains, voilà qui va me faire gagner du temps.
Pour le moment, il me semble urgent ... d'attendre !
Du coup je vais voir coté Navette.
OK pour AMSO. Oui, c'est une merveille et en Orbiter 2016 il fonctionne globalement sans problème. J'ai testé toutes les missions que je m'étais organisées. Seules celles pour les corrections de trajectoires avec IMFD semblent poser des difficultés. reste que l'alunissage ... avec le relief est vraiment fabuleux.

La sagesse est un trésor ... tellement bien caché.

Offline Pappy2

  • Legend
  • ******
  • Posts: 6752
  • Country: France fr
  • Karma: 312
Reply #6 - 25 November 2020, 11:05:09
Alors concernant la navette spatiale et Orbiter 2016 un gros paquet "surprise" va bientôt sortir  :eek:

J'ai mis un peu d'infos ici:
http://orbiter.dansteph.com/forum/index.php?topic=14362.msg217579#msg217579

@+ Pappy2_________
Citation célèbre:
Lorsque la trajectoire Képlérienne du mobile coupe la sphère du géoïde de l'astre de capture, ce n'est généralement pas très bon pour l'avenir du beau vaisseau et de son équipage
"Nulentout"

Offline asterazy

  • Entre Kourou et Nantes...
  • Jr. Member
  • **
  • Posts: 39
  • Country: French Guiana gf
  • Karma: 9
  • far and beyond
Reply #7 - 02 December 2020, 22:35:42
Bon j'ai l'impression que je vais me retrouver avec de nouvelles fiches à tester moi  :bave: