See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: sound 3.5 to 4.0  (Read 611 times)

0 Members and 1 Guest are viewing this topic.

Offline gattico

  • Sr. Member
  • ****
  • Posts: 317
  • Country: United States us
  • Karma: 8
24 October 2020, 00:42:21
MoonBase Alpha was built using 3.5.  We have upgraded to 4.0.
cpp:
#include "orbitersdk.h"
#include "MOONBASEALPHA2.h"
#include "MOONBASEMESH.h"
#include "OrbiterSoundSDK40.h"
#include "ColorNames.h"

Code: [Select]
void MOONBASEALPHA2::clbkPostCreation (void)
{{
DWORD mode=GetADCtrlMode ();
mode|=32;
SetADCtrlMode (mode);
}
MOONBASEALPHA2ID=ConnectToOrbiterSoundDLL(GetHandle());
ReplaceStockSound(MOONBASEALPHA2ID,"Sound\\Vessel\\MOONBASEALPHA\\ambient.wav", REPLACE_COCKPIT_AMBIENCE_1);
RequestLoad3DWaveMono(MOONBASEALPHA2ID,AIRLOCKCLOSE,"Sound\\Vessel\\MOONBASEALPHA\\airlockclose.wav",BOTHVIEW_FADED_FAR, &_V(0,0,2));
RequestLoad3DWaveMono(MOONBASEALPHA2ID,ELEVATOR,"Sound\\Vessel\\MOONBASEALPHA\\elevatorupdown.wav",BOTHVIEW_FADED_FAR, &_V(0, 0, 2));
RequestLoad3DWaveMono(MOONBASEALPHA2ID,DOORCLOSE,"Sound\\Vessel\\MOONBASEALPHA\\doorclose.wav",BOTHVIEW_FADED_FAR, &_V(0, 0, 2));
RequestLoad3DWaveMono(MOONBASEALPHA2ID,RAIL,"Sound\\Vessel\\MOONBASEALPHA\\electric1.wav",BOTHVIEW_FADED_FAR, &_V(0, 0, 2));
RequestLoad3DWaveMono(MOONBASEALPHA2ID,CRANE,"Sound\\Vessel\\MOONBASEALPHA\\electric.wav",BOTHVIEW_FADED_FAR, &_V(0, 0, 2));
SoundOptionOnOff(MOONBASEALPHA2ID,PLAYMAINTHRUST,FALSE);

SoundOptionOnOff(MOONBASEALPHA2ID,PLAYHOVERTHRUST,FALSE);
SoundOptionOnOff(MOONBASEALPHA2ID,PLAYATTITUDETHRUST,FALSE);

SoundOptionOnOff(MOONBASEALPHA2ID,PLAYCOUNTDOWNWHENTAKEOFF,FALSE);

SoundOptionOnOff(MOONBASEALPHA2ID,PLAYCABINAIRCONDITIONING,TRUE);

SoundOptionOnOff(MOONBASEALPHA2ID,PLAYCABINRANDOMAMBIANCE,TRUE);

SoundOptionOnOff(MOONBASEALPHA2ID,PLAYRADIOATC,FALSE);

SoundOptionOnOff(MOONBASEALPHA2ID,DISPLAYTIMER,FALSE);
}// Constructor

Got the sdk loaded.

Here is the sound log:
********************************************************
OrbiterSound 4.0 (3D) Build Nov 20 2012 01:00
********************************************************

Orbiter version: 100830








Advanced OrbiterSound settings: (Edit: 'Sound/cfg/Editable_Advanced_Configuration.cfg')
-------------------------------
Primary buffer         22050hz 16bits  (default 22050/16)
DopplerFactor         1.00      (default 1.00)
VaccumAttenuationFactor      1.00      (default 1.00)
SoundDistanceFactor      1.00      (default 1.00)
MaxSoundProcessPerSecond   60      (default 60)
MaxAnimCheckPerFrame      10      (default 10)
PlayWhenOrbiterInBackground   false      (default false)
WriteInLogAllLoadedSound   false      (default false)
-------------------------------

Orbiter directory:  D:\orbiter100830\
Listing planets winds and bases sounds:
  6 planet wind sound found
  4 bases sound found
Passed initModule - Ok
Vessel MBATCAR requested an ID, returned= 0 OK
Vessel TECHWING2 requested an ID, returned= 1 OK
Vessel DINING requested an ID, returned= 2 OK
Vessel ALPHARING requested an ID, returned= 3 OK
Vessel TCARHYDRO requested an ID, returned= 4 OK
Vessel tcar2comp requested an ID, returned= 5 OK
Vessel TCARLP4 requested an ID, returned= 6 OK
Vessel COMMANDCENTER requested an ID, returned= 7 OK
Vessel Eaglehangar requested an ID, returned= 8 OK
Vessel NEWWP requested an ID, returned= 9 OK
Vessel ACT1 requested an ID, returned= 10 OK
Vessel DEPOT requested an ID, returned= 11 OK
Vessel tpad requested an ID, returned= 12 OK
Vessel JDome4 requested an ID, returned= 13 OK
Vessel FUELSTORE requested an ID, returned= 14 OK
Vessel CenturiL requested an ID, returned= 15 OK
Vessel CenturiM requested an ID, returned= 16 OK
Vessel pass1 requested an ID, returned= 17 OK
Vessel RECON2 requested an ID, returned= 18 OK
Vessel UMmu_99C-Michael_Ryan requested an ID, returned= 19 OK
MFD Requested an ID: UMmuRadio Assigned ID=0 OK
Vessel UMmu_99FR-Eileen_Ripley requested an ID, returned= 20 OK
Vessel UMmu_99FM-Tanya_Aleksandr requested an ID, returned= 21 OK
Vessel UMmu_99C-John_Koenig requested an ID, returned= 22 OK
Vessel UMmu_99FD-Helena_Russell requested an ID, returned= 23 OK
Vessel UMmu_99S-Tony_Allan requested an ID, returned= 24 OK
Vessel UMmu_99M-Paul_Morrow requested an ID, returned= 25 OK
Vessel UMmu_99T-Mark_Dominix requested an ID, returned= 26 OK
--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL3: Unable to connect to OrbiterSound 3.5 - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

--------------------------------------
ERR01= Vessel->ConnectToOrbiterSoundDLL: Unable to connect to OrbiterSound - not installed or activated

« Last Edit: 24 October 2020, 01:16:03 by gattico »

Offline gattico

  • Sr. Member
  • ****
  • Posts: 317
  • Country: United States us
  • Karma: 8
Reply #1 - 24 October 2020, 01:36:53
So weird.  in regular graphics  I get sound but not in d3d9


Offline gattico

  • Sr. Member
  • ****
  • Posts: 317
  • Country: United States us
  • Karma: 8
Reply #2 - 25 October 2020, 04:22:46
I had to make sure the sounds were in the server side like sc3