See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: un petit souci avec AMSO  (Read 689 times)

0 Members and 1 Guest are viewing this topic.

Offline samtlgeek

  • Jr. Member
  • **
  • Posts: 13
  • Country: France fr
  • Karma: 1
  • LEM and CM
08 July 2018, 12:42:39
en gros, je sais pas trop ou mettre tout les fichiers. j'ai essayé d'extraire directement le mod dans le dossier Orbiter2010 et j'ai aussi tenté de mettre les configs avec les configs, les textures avec les textures etc...
a chaque fois: error, see orbiter.log for more details
si quelqu'un a la solution, merci de me la donner :wor:
Samtlgeek

jim lovell

Offline Milouse

  • Legend
  • ******
  • Posts: 1327
  • Country: France fr
  • Karma: 108
Reply #1 - 08 July 2018, 13:34:36
Bonjour,

C'est exactement ce qu'il faut faire : conserver l'arborescence des fichiers. Normalement, il y a un sous-dossier AMSO dans chacun des dossiers principaux d'Orbiter (Orbiter2010\Config\AMSO\..., Orbiter2010\Meshes\AMSO\..., etc.).
Il est conseillé d'installer AMSO dans une installation séparée d'Orbiter2010, qui lui sera dédiée.
Ouvre le fichier Orbiter2010\orbiter.log avec un éditeur de texte (le Bloc-notes par ex.). Si tu ne comprends pas l'erreur, copie-colle l'intégralité du texte et poste-le ici.


Milouse


Offline samtlgeek

  • Jr. Member
  • **
  • Posts: 13
  • Country: France fr
  • Karma: 1
  • LEM and CM
Reply #2 - 08 July 2018, 18:56:01
d'ac, j'essaye ca tout de suite

Post Merge: 08 July 2018, 19:03:34
pas marché  :sad: voici le dossier :
**** Creating simulation session
DirectDraw interface OK
Direct3D interface OK
Graphics: Viewport: Window 1194 x 725 x 32
Graphics: Hardware T&L capability: Yes
Graphics: Z-buffer depth: 32 bit
Graphics: Active lights supported: 8
Loading 15382 records from star database
---------------------------------------------------------------
>>> ERROR: While initialising solar system AMSO\Sol:
>>> File not found: .\Config\AMSO\Sol.cfg
>>> [Orbiter::CreateRenderWindow | .\Orbiter.cpp | 726]
---------------------------------------------------------------
>>> TERMINATING <<<


j'avais deja vu cette erreur dans un autre post mais j'ai pas trop compris comment la régler

merci :wor:

« Last Edit: 08 July 2018, 19:03:34 by samtlgeek »
jim lovell

Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 5922
  • Country: France fr
  • Karma: 308
  • Plus on rate, plus on a de chances de réussir !..
Reply #3 - 08 July 2018, 19:33:56
C'est cette ligne qui dit tout :
>>> File not found: .\Config\AMSO\Sol.cfg

Orbiter cherche le fichier Sol.cfg dans le dossier <ton orbiter>\Config\AMSO\

2 solutions pour régler le problème :
1) tu cherche si ce fichier n'est pas mal installé (regarde dans l'archive.zip de AMSo)
    et tu le mets dans le dossier \Config\AMSO
    (ou alors tu fais un double du fichier \Config\Sol.cfg
2) ou alors tu édites ton fichier scn et tu remplace la ligne dans la section
BEGIN_ENVIRONMENT
  System AMSO\Sol
  Date MJD 58215.5662152778
END_ENVIRONMENT
par
BEGIN_ENVIRONMENT
  System Sol
  Date MJD 58215.5662152778
END_ENVIRONMENT

Voilà.

Je pense que le plus simple :
Regarde dans le dossier \Config\AMSO
il doit y avoir ces 3 fichiers :

Earth.cfg
Moon.cfg
Sol.cfg

Sinon prends ceux qui sont dans \Config
et fais-en des doubles que tu colle dans  \Config\AMSO

Mais attention : le fichier Moon.cfg est un peu différent dans \Config\AMSO que dans \Config

(mais tu ne risque rien)

Tiens nous au courant...


P.S. quand tu décompresse l'archive AMSO, fais bien attention de bien activer l'option "utiliser nom de dossier" et tu dézippe dans le dossier "racine" de ton Orbiter.
Tout doit se mettre en place comme il faut....

« Last Edit: 08 July 2018, 19:40:50 by jacquesmomo »
Mes add-ons sont là !

Offline samtlgeek

  • Jr. Member
  • **
  • Posts: 13
  • Country: France fr
  • Karma: 1
  • LEM and CM
Reply #4 - 08 July 2018, 19:49:01
ok merci, j'essaye tout ca et je vous tiens au courant

Post Merge: 08 July 2018, 19:59:09
alors, j'ai essayé de dézipper avec the unarchiver : non
         remplacé le fichier sol.cfg par une copie de celui venant de config/sol.cfg : non
         je crois savoir d'ou vient le problème : je n'ai aucun fichier AMSO créé dans config, textures etc. les seuls fichiers AMSO présents sont dans monorbiter/AMSO/config
je précise que je suis sur mac et que je fais tourner orbiter avec wineskin. mais cela ne change en rien les dossiers d'orbiter


Post Merge: 08 July 2018, 20:06:35
ps: j'ai toujours la même erreur "sol.cfg"

Post Merge: 08 July 2018, 20:13:55
re ps: j'ai réessayé en changeant le fichier scn et la:

Finished initialising world
>>> ERROR: No vessel class configuration file found for:
---------------------------------------------------------------
>>> ERROR: AMSO\Apollo
>>> [Vessel::OpenConfigFile | .\Vessel.cpp | 252]
---------------------------------------------------------------
>>> TERMINATING <<<

« Last Edit: 08 July 2018, 20:13:55 by samtlgeek »
jim lovell

Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 5922
  • Country: France fr
  • Karma: 308
  • Plus on rate, plus on a de chances de réussir !..
Reply #5 - 08 July 2018, 23:41:25
ben même chose : Orbiter cherche un fichier "Apollo.cfg" qui doit se trouver dans le dossier "<ton_orbiter>\Config\Vessels\AMSO et donc il ne le trouve pas....

voici une capture de mon dossier \Config\Vessels\AMSO



si tu n'as pas ça, c'est que ton dézippage ne mets pas les fichiers où il faut....


:zen: rôôôôôôôô


Et d'ailleurs ce que tu nous dit :
monorbiter/AMSO/config

ben c'est pas possible....
En effet, dans le dossier Orbiter il n'y a pas de sous dossier "AMSO".
Les dossiers "AMSO" sont des sous dossiers de config, vessels, textures, meshes, mais pas là....

Donc il y a bien un problème de chemin après ton dézippage....

:zen: rogntudjudemac...




Mes add-ons sont là !

Offline samtlgeek

  • Jr. Member
  • **
  • Posts: 13
  • Country: France fr
  • Karma: 1
  • LEM and CM
Reply #6 - 09 July 2018, 09:53:38
Ok je vais essayer de placer manuellement chaque dossier AMSO dans le bon dossier et je vous tiens au courant

jim lovell

Offline Papyref

  • Legend
  • ******
  • Posts: 4844
  • Country: France fr
  • Karma: 200
  • Je suis dans la Lune ne pas me déranger
Reply #7 - 09 July 2018, 10:35:02
Normalement si tu utilises WinZip pour décompacter directement dans ton dossier Orbiter les fichiers se placent dans les bons dossiers


Offline samtlgeek

  • Jr. Member
  • **
  • Posts: 13
  • Country: France fr
  • Karma: 1
  • LEM and CM
Reply #8 - 09 July 2018, 13:03:04
J’essaye tout ça ce soir merci de votre aide  :beer:

jim lovell

Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 5922
  • Country: France fr
  • Karma: 308
  • Plus on rate, plus on a de chances de réussir !..
Reply #9 - 09 July 2018, 14:46:02
Papyref a raison !!!

ET n'oublie pas (option normalement activée par défaut avec winzip)  "utiliser nom de dossier"

:zen: macmacmacmac

Mes add-ons sont là !

Offline samtlgeek

  • Jr. Member
  • **
  • Posts: 13
  • Country: France fr
  • Karma: 1
  • LEM and CM
Reply #10 - 10 July 2018, 10:03:25
J’ai tout extrait avec Winzip, les dossiers se sont bien placés mais toujours une erreur sauf que cette fois, il n’y a rien écrit dans Orbiter.log  :sad:

jim lovell

Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 5922
  • Country: France fr
  • Karma: 308
  • Plus on rate, plus on a de chances de réussir !..
Reply #11 - 10 July 2018, 13:08:00
Bon.... ça avance...  :badsmile:

Efface le fichier "orbiter.log" , relance un scénario quelconque, et re-regarde dans ce fichier et dis nous ce qu'il y a...
(sinon, si tu lance un scn d'origine de orbiter, ça marche ???)

 :rant: on va bien y arriver, tout de même...

Mes add-ons sont là !

Offline samtlgeek

  • Jr. Member
  • **
  • Posts: 13
  • Country: France fr
  • Karma: 1
  • LEM and CM
Reply #12 - 10 July 2018, 22:12:06
je comprends pas...maintenant le fichier log reste vide peut importe le scenario...

je vais tenter une réinstallation d'orbiter et je vous tiens au courant

Post Merge: 10 July 2018, 22:49:52
ca y est ! après une réinstallation propre, tout marche correctement  :music: merci beaucoup de votre aide les gars, je vous laisse, ma saturn V m'attend...

« Last Edit: 10 July 2018, 22:49:52 by samtlgeek »
jim lovell

Offline jacquesmomo

  • Le budget !!!
  • Legend
  • ******
  • Posts: 5922
  • Country: France fr
  • Karma: 308
  • Plus on rate, plus on a de chances de réussir !..
Reply #13 - 11 July 2018, 19:04:27
ca y est ! après une réinstallation propre, tout marche correctement  :music: merci beaucoup de votre aide les gars, je vous laisse, ma saturn V m'attend...
Plus on rate etc....  :badsmile: :badsmile:

tu vois, on y arrive toujours !!! Bon vol avec AMSO, mon addon préféré !!!
(merci encore ACSoft !!!!) :wor:

Mes add-ons sont là !

Offline samtlgeek

  • Jr. Member
  • **
  • Posts: 13
  • Country: France fr
  • Karma: 1
  • LEM and CM
Reply #14 - 11 July 2018, 23:46:44
merci jacques, et merci tout le monde :)

jim lovell

Offline ACSoft

  • Full Member
  • ***
  • Posts: 187
  • Karma: 19
Reply #15 - 13 July 2018, 11:12:07
tu vois, on y arrive toujours !!! Bon vol avec AMSO, mon addon préféré !!!
(merci encore ACSoft !!!!) :wor:

Très touché, jacquesmomo !   ;) ;) ;)

Bon vol, samtigeek !