See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: [Closed] OrbiterSound 4.0 Release candidate 1  (Read 13709 times)

0 Members and 1 Guest are viewing this topic.

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
10 November 2012, 02:31:52
Welcome to OrbiterSound 4.0 beta test ver 20121110


Current version test special instructions

Please review the changelog here:
Changelog: http://www.dansteph.com/publie/ChangeLog_OrbiterSound.txt

Check that your bug are gone and report !


Bug reporting form

Please use the text form in the link below to report bugs: It's important !
http://www.dansteph.com/publie/beta_form_OrbiterSound.txt


Compatible Orbiter version

Orbiter 2010+P1
Orbiter 2010+P1+ DX9 or DX11 (Note: You don't need symlink anymore for DX9 or DX11)
Orbiter 2010+P2 Only version PREVIOUS TO the latest 22 Oct release which is an alpha with many problems as reported by martin.



Feedback

Feedback are importants, please be verbous, precise, don't hesitate to write what you think or post anything you want about beta.  Use the form above for bugs. Keep me informed of any status change if you can't test anymore for example.


Much thanks for your help :beer:

Dan


Offline cslevine

  • Legend
  • ******
  • Posts: 3621
  • Karma: 17
Reply #1 - 10 November 2012, 11:52:23
Wow the crackling re-entry sound is exactly what i was waiting for. Real experience !   :hot:

Quote
in true they don't hear the crackles due to supersonics vortex
( Dansteph mp )
but i think maybe more louder sound into the cockpit view version would be good, because mix with airspeed, and would be some "cheat" for more "gaming experience". A choice to make for the user in Soundconig...
or... hmm... always + always +... if not time taking... in Orbitersound
one volume for external re-entry sound
one volume for cockpitview re-entry sound.
... not at all mandatory. i write that in smallgrey



{ tip : in your final videos, put the external view sometimes with the sound, and tometimes without, because the sound is not transmitted in high altitude of the reentry, instead if we are behind the vihecule...
( but who instead Superman will be able to ...hear someting at this place )
}


Super job :top:   !!!


Sorry don't have much time today and tomorrow for testing again if all other sounds still working fine.



Message modifié ( 10-11-2012 11:52 )


Offline SolarLiner

  • Global Moderator
  • Legend
  • *****
  • Posts: 2769
  • Country: France fr
  • Karma: 55
  • a été remercié par Le Créateur
Reply #2 - 10 November 2012, 13:21:07
Ouch !
Reentry time in my DGIV ... With hypoxia sound already there (see my DGIV Bug post) and it is awesome ! Great sound you found !
One sound to keep in my More Sound add-on :)



Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #3 - 10 November 2012, 13:57:56
Quote
SolarLiner a écrit:
Reentry time in my DGIV ... With hypoxia sound already there (see my DGIV Bug post) and it is awesome ! Great sound you found !

Made with several parts of real and produced sound ;) (Yes the crackles are from the real shuttle taking off)


Offline jgrillo2002

  • Full Member
  • ***
  • Posts: 130
  • Country: United States us
  • Karma: 5
Reply #4 - 11 November 2012, 02:47:24
Very awesome release. no problems so far



Offline hedzup456

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Reply #5 - 11 November 2012, 17:27:39
First impression:Love it!
Second impression: REALLY love it!
Third impression: where's my wallet, I need 5.1 surrounds!
In all seriousness, however, 4.0 of OS is amazing. I have been playing for the most part of the afternoon, and I honestly love the 3D sounds, as well as the sound cones-That, Dan, is a little piece of genius.
More comments coming soon.
~Hedz
---------------------------------edit-------------------------------------------------
One bug I noticed, is that the DGIV doesn't have any external reentry sound-even behind the ship. It could be just the fact that I was too high, but I was getting the "flame affect". I would have told you if it started after decent, but I nudged my joystick, and burned up. Ah.



Post Edited ( 11-12-12 10:48 )

~Hedz

Offline MerciMartin

  • Sr. Member
  • ****
  • Posts: 399
  • Karma: 4
Reply #6 - 12 November 2012, 00:05:03
Nothing bad to report !
All is good (and sometimes so good that i forgot to test)
Reentry sound cone is another good feature.


Offline dgatsoulis

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 15
Reply #7 - 12 November 2012, 01:59:51
Can someone check if the cabin air-conditioning sound in the default DG loops properly?

I'm getting a weird drop in volume every 30 seconds in the internal view. (VC, panel and glass cockpit). I am using the default settings in the OrbiterSoundConfig.

I'm sorry I'm not posting a proper report, but I just noticed it and it's really late here. I'll check again tomorrow and post a proper report if the problem persists. In the meantime, it would be great if any of the other testers could check as well.


“The trouble with quotes on the internet is that it’s difficult to discern if they are genuine.”
-Winston Churchill

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #8 - 12 November 2012, 02:31:29
The wav is 3 second for the DG aircond, so it's not a looping problem.
Waiting more test to see what is happening here.


Offline Ripley

  • Full Member
  • ***
  • Posts: 98
  • Country: Italy it
  • Karma: 12
    • My Orbiter section on www.tuttovola.org
Reply #9 - 12 November 2012, 11:52:56
When I first installed and launched it, I noticed some typos on the initial welcome text.
Now it doesn't appear anymore and I don't know how to help translating it.


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #10 - 12 November 2012, 11:58:53
Quote
Ripley a écrit:
When I first installed and launched it, I noticed some typos on the initial welcome text.
Now it doesn't appear anymore and I don't know how to help translating it.

Install again the message should come back until you press space...
Anyway here it is:

Quote
What's new in OrbiterSound 4.0:

- 3D audio effects (placement of sounds in three-dimensional space)
- You can design all vessels' sounds by configuration files
- Compatible with latest graphic clients (tested on DX9 & DX11)

Much more was added or changed; to know all the new features
test demo scenarios and read the documentation (in 'Orbiter/Doc/').


Press SPACE key to continue (this notice will never show again).



Offline Ripley

  • Full Member
  • ***
  • Posts: 98
  • Country: Italy it
  • Karma: 12
    • My Orbiter section on www.tuttovola.org
Reply #11 - 12 November 2012, 14:43:06
Just very minor things at this stage:
-------------------------------------

What's new in OrbiterSound 4.0:

- 3D audio effects (placement of sounds in three-dimensional space)
- You can design all vessels' sounds by configuration files
- Compatible with latest graphics clients (tested on DX9 & DX11)

Much more was added or changed: in order to experience every new feature,
please test demo scenarios and read the documentation (in 'Orbiter/Doc/').


Press SPACE key to continue (this notice will never show again).


Offline Scattykat

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Reply #12 - 12 November 2012, 15:07:23

ORBITERSOUND BUG


Short description:
Despite SoundConfig.exe and vessel config files being set up for ATC chatter, the Arrow Freighter Radio / Radar / MP3 mfd states:
Quote
---VHF---
ATC Chatter disabled in options or vessel config
Press Mut to enable tempory use SoundConfig.exe and/or edit vessel config to enable permanently)

If I press Mut, as instructed, then the ATC chatter starts

This only seems to be occurring for the Arrow - all other space craft Radio / Radar / MP3  mfd state
---VHF---
Com Status: On

Severity

Minor

Complete description


My OrbiterSound.exe setup is as follows:


And my Arrow vessel config is:
Quote
; === Configuration file for vessel class UCGO Arrow - By Dansteph http://httP://orbiter.dansteph.com ===
ClassName = UCGOArrow
Module = UCGOArrow
ImageBmp =Images\UCGOArrow\UCGO_Arrow.bmp

;--------------------------------------------------------------
;HERE BELOW ARE THE VALUE YOU CAN CONFIGURE TO CHANGE BEHAVIOUR
;OF THE MOTHER SHIP UCGO ARROW FREIGHTER 18
;--------------------------------------------------------------
;NOTE: GOOD VALUE TO TAKE OFF FROM EARTH: "HOVER_THRUST_POWER=60.0e6"
;      The Arrow was NOT designed for atmospheric rentry. Autoland
;      will only work at low speed low altitude in this case.
;      Deactivating angular limiter may show odd behaviour off autopilots.


ANGULAR_DAMPER_ACTIVATED           =1   ; Limit the angular velocity (0=deactivate 1=activate)
RADIO_CHATTER_PLAYDELAY      =2   ; Chatter Delay in fonction of altitude 3= long delay 2=medium delay 1=short delay
VESSEL_NEED_CREW                      =0   ; Disable ship control if no crew aboard (1=disable 0=enable always)
MONTH_OXYGEN_RESERVE              =28   ; O2 reserve in month for a full crew of 20 (max 96 month)
MAIN_THRUST_POWER              =50e6   ; Power of main thrust in newton.
RCS_THRUST_POWER                      =13e5   ; Power of RCS thrust in newton.
HOVER_THRUST_POWER              =60.0e6   ; Power of Hover Thrust in newton. (change to 60.0e6 to take-off from earth)
ISP                                    =50e4   ; ISP (Change fuel consumption)
ENABLE_MAD_GRAVITY_WHEEL           =0   ; For those that love gravity wheel turning like a mad during long trip
                                        ; put "1" to disable the code that make it independent of time acceleration.
ENABLE_AMBIANCE_SOUND      =1   ; Enable tiny rumble and pump sound effect that are played from time to time
                ; in cockpit


Reproduce bug

This happens for all Arrow ships I have tested

Tested in sceario - \Scenarios\_UniversalCarsandCargos (UCGO)\Mother ship - Arrow Freighter\SPOILER - Europa landing area

Miscallenous

In view of all the other ships being ok, is this just an Arrow issue and not a Sound 4.0 issue?



Post Edited ( 11-12-12 15:11 )


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #13 - 12 November 2012, 15:31:34
Quote
Scattykat a écrit:
In view of all the other ships being ok, is this just an Arrow issue and not a Sound 4.0 issue?

In fact the Arrow's ATC chatter is a private chatter not related to OrbiterSound's built in ATC.
So it's not a bug.


Offline Scattykat

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Reply #14 - 12 November 2012, 18:22:29
Quote
DanSteph wrote:
Quote
Scattykat a écrit:
In view of all the other ships being ok, is this just an Arrow issue and not a Sound 4.0 issue?

In fact the Arrow's ATC chatter is a private chatter not related to OrbiterSound's built in ATC.
So it's not a bug.

Thanks Dan,

Will this statement to press Mut always appear in the Arrow MP3 mfd then?

:beer:



Offline dgatsoulis

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 15
Reply #15 - 12 November 2012, 18:33:47
Quote
dgatsoulis wrote:
Can someone check if the cabin air-conditioning sound in the default DG loops properly?

I'm getting a weird drop in volume every 30 seconds in the internal view. (VC, panel and glass cockpit). I am using the default settings in the OrbiterSoundConfig.

I'm sorry I'm not posting a proper report, but I just noticed it and it's really late here. I'll check again tomorrow and post a proper report if the problem persists. In the meantime, it would be great if any of the other testers could check as well.


False alarm, the airconditioning sound is ok. I reopened the PC today and had no problems. I wasn't able to reproduce that weird volume drop that was happening yesterday every 30 seconds. I tried it on the headset and on quadrophonic, everything was ok.


“The trouble with quotes on the internet is that it’s difficult to discern if they are genuine.”
-Winston Churchill

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #16 - 12 November 2012, 23:19:04
Reminder for me:

-Don't remove /Vessel/ folder even if "uninstall" checked
-Remove the 3.5 help.html


Offline cipher169

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
Reply #17 - 13 November 2012, 01:40:40
Nice Job so far. The new release works great for me. I also love the new reentry sound.


Offline paddy2

  • Newbie
  • *
  • Posts: 11
  • Country: United Kingdom gb
  • Karma: 0
Reply #18 - 13 November 2012, 02:54:53
Not able to test until wedensday



Offline cslevine

  • Legend
  • ******
  • Posts: 3621
  • Karma: 17
Reply #19 - 13 November 2012, 09:53:12
Suggestion :
maybe, now, for the release, remove the underscore _ before the 3 folders, because they are 3, they become more visible.
and before the scenaries folder. It will come just before "Playback" that is one of the most viewed  ;)
( but i know that this could bring a bug if there is a little missing in the code )

or - idea - use the underscore for your main addons : UCGO, UMMU  ;)   because they are main.
( they have Add's of Addons... )
( Arrow is a vessel )
( DG-IV is a vessel )

priority :
the lowest priority.
...After multivessel   :)



Message modifié ( 13-11-2012 09:56 )


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #20 - 13 November 2012, 11:45:47
Quote
cslevine a écrit:
Suggestion :
maybe, now, for the release, remove the underscore _ before the 3 folders

That would be like changing the wings of an aircraft at the last moment after all the tests.
Many code reffer to those folder name, beta would need to be restarted. ;)

The underscore ensure they are all listed at top. A litle visual help.

Dan



Message modifié ( 13-11-2012 12:55 )


Offline gattico

  • Sr. Member
  • ****
  • Posts: 337
  • Country: United States us
  • Karma: 15
Reply #21 - 13 November 2012, 12:50:26
Not sure if this is a bug.  But if you have an older version 3.5 and it detects it and you answer yes it replaces the Vessel/sound/  folder.  So if you have any vessel folders there they get replaced.  If you answer NO then they remain intact


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #22 - 13 November 2012, 12:55:05
Quote
gattico a écrit:
Not sure if this is a bug.  But if you have an older version 3.5 and it detects it and you answer yes it replaces the Vessel/sound/  folder.  So if you have any vessel folders there they get replaced.  If you answer NO then they remain intact

I have changed that, now the 'Sound/Vessel' folder isn't deleted in any case. (In the incoming version)


Offline dgatsoulis

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 15
Reply #23 - 16 November 2012, 23:10:36
I've been using Orbiter normally all this week, nothing new to report except this typo, which eventhough has been reported twice, keeps popping up on every version :wall:  

:) :) :)



Everything addon I have tried is running smoothly, nothing new to report.

EDIT: the suit for the new UMMU looks amazing!!! :applause:



Post Edited ( 11-16-12 23:12 )

“The trouble with quotes on the internet is that it’s difficult to discern if they are genuine.”
-Winston Churchill

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #24 - 16 November 2012, 23:49:15
Quote
dgatsoulis a écrit:
I've been using Orbiter normally all this week, nothing new to report except this typo, which eventhough has been reported twice, keeps popping up on every version

Strange, I recall having edited it, might be during transfert of differents version for correction.
Anyway I just corrected it (again :badsmile: )

Next (and last?) version soon.

Dan