See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: [closed] UCGO beta test ver 091209  (Read 33977 times)

0 Members and 1 Guest are viewing this topic.

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #75 - 12 December 2009, 02:30:39
Quote
Murdock a écrit:
I saw a bunch of error loading the cars. Maybe we are on the right way...


AAaaah I think I get it, please do this below careffully.


1-First download this file:
http://www.dansteph.com/publie/UCGOCars_A.zip

2-Unzip it into Orbiter/modules directory , pay great attention to replace the existing UCGOCars.dll

3-Test cars in orbiter. If my thought is correct it should not work but this test is just to no get a false positive
and confirm the problem.

4-Exit orbiter.


5-Then only download this one:
http://www.dansteph.com/publie/UCGOCars_B.zip

6-Same as above unzip in "modules" directory, pay great attention to replace the existing UCGOCars.dll (the size of
this one is bigger than the older)


7-Test Orbiter & magic , it work :)

Dan


Offline Dambuster

  • Jr. Member
  • **
  • Posts: 39
  • Karma: 0
Reply #76 - 12 December 2009, 09:46:36
----------------------------------------------------------------------

UCGO BUG


Bug with:

DGIV


Short description:

Smoke effects display oddly


Severity

Detail


Complete description

When (crash-)landed on Mars, I found that the effects which generally (at least on Earth) show smoke coming out of the vents
near the back of the DGIV when on the runway weren't displaying properly.  Instead of each puff of smoke falling gently to
the ground, they were descending to the ground, but then bouncing up several thousand feet instead.


Reproduce bug


As far as I can tell, you need to crash-land a DGIV, so that your gear (and maybe hover engines?) are destroyed.


Miscallenous

There is a chance that this may not be the same effect as the 'vapour coming out of the vents', but rather an
'engine-destroyed' effect...


Offline Fox-Terrier

  • League of
  • Legend
  • ******
  • Posts: 1426
  • Country: Switzerland ch
  • Karma: 28
  • :D
Reply #77 - 12 December 2009, 10:20:49
I noticed this too, but this bug already exists in DGIV 1. the lower framerate you have, the higher the smoke balls bounces



Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #78 - 12 December 2009, 11:23:39
Backward/Forward fixed, for the smoke I don't have any control on puff once released so this might be an orbiter bug ?
In anyway I'll not rework the DGIV it will remain a "minor" update (opening UCGO world to DGIV is not minor I think but... :) )

Reason: Prelude base could be made breathable with ucgo consumable/reserve etc. etc. There is again one/two month of work on
DGIV to make a full/cool update and I don't have this time.

Dan


Offline Dambuster

  • Jr. Member
  • **
  • Posts: 39
  • Karma: 0
Reply #79 - 12 December 2009, 11:33:51
Ok, I've got a series of minor, maybe non-bugs that I'll be posting soon once I've investigated them a bit more.


Offline sunshine135

  • Hero Member
  • *****
  • Posts: 547
  • Country: United States us
  • Karma: 3
  • I fly by the seat of my pants!
Reply #80 - 12 December 2009, 13:30:43

UCGO BUG


Bug with:

Arrow freighter


Short description:

EVA Texture Backwards


Severity

Detail


Complete description
On the bottom of the EVA airlock, the word EVA is backwards


Reproduce bug

Egress a Ummu and look at the bottom of the airlock


Miscallenous
Probably just a repeat of the texture that causes the letter reversal. We see this on the DGIV on the rudders when placing a
letter or number. This helps keep poly count low. May have to live with this or have Dan consider placing EVA above the
airlock versus on the airlock.


"Sun Dog"

Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #81 - 12 December 2009, 14:54:45
No it's a feature, there is no "top" or "bottom" in space and a Crew might float head up side down ;)

Dan


Offline gattico

  • Sr. Member
  • ****
  • Posts: 337
  • Country: United States us
  • Karma: 15
Reply #82 - 12 December 2009, 15:28:27

UCGO BUG


Bug with:

(all cars)


Short description:

(Can't turn and accelerate and the same time)


Severity

( serious)


Complete description

(I pressed up arrow for gas but couldn't turn use 4 on keypad.  I could turn if I let stop holding down the up arrow
key.)


Reproduce bug

(Start drive all cars select Chrysler and give it gas and try to turn.)


Miscallenous

(If you have comments or something to add)


Offline the.punk

  • Jr. Member
  • **
  • Posts: 80
  • Karma: 0
Reply #83 - 12 December 2009, 15:30:16
Quote
gattico wrote:

UCGO BUG


Bug with:

(all cars)


Short description:

(Can't turn and accelerate and the same time)


Severity

( serious)


Complete description

(I pressed up arrow for gas but couldn't turn use 4 on keypad.  I could turn if I let stop holding down the up arrow
key.)


Reproduce bug

(Start drive all cars select Chrysler and give it gas and try to turn.)


Miscallenous

(If you have comments or something to add)

I think this isn't a bug. It's not implemented.



Post Edited ( 12-12-09 15:33 )



Offline Fox-Terrier

  • League of
  • Legend
  • ******
  • Posts: 1426
  • Country: Switzerland ch
  • Karma: 28
  • :D
Reply #84 - 12 December 2009, 15:44:09
it is a feature I think.
perhaps because it isn't implemented in the autopilot which speed you should go if you turn abruptly (breaking) but
accelerating at the same time



Offline Fox-Terrier

  • League of
  • Legend
  • ******
  • Posts: 1426
  • Country: Switzerland ch
  • Karma: 28
  • :D
Reply #85 - 12 December 2009, 15:50:47
a funny thing : take a UMMU, open F3 (vessel selector), put the mouse back out of the box, go forward and turn at the same
time, simultaneously bring the mouse back in the box (vessel selector box)


TADAAA ! a UMMU which runs in circles eternally

afterwards you can change view and look the ummu through the eyes of another ummu

that is my way of autopiloting UMMUs

have fun :turning:



Offline Nemoricus

  • Jr. Member
  • **
  • Posts: 39
  • Karma: 0
Reply #86 - 12 December 2009, 16:11:18
I think that that's an Orbiter bug. You can do something similar with URMS. Hold down a numpad button to move a part of the
arm, then move your cursor over the control dialogue box. It will keep moving according to the button that was pressed, even
if you release it.


Offline Fox-Terrier

  • League of
  • Legend
  • ******
  • Posts: 1426
  • Country: Switzerland ch
  • Karma: 28
  • :D
Reply #87 - 12 December 2009, 16:29:33
I know it is. it's just funny sometimes



Offline sunshine135

  • Hero Member
  • *****
  • Posts: 547
  • Country: United States us
  • Karma: 3
  • I fly by the seat of my pants!
Reply #88 - 12 December 2009, 17:52:22
Quote
DanSteph wrote:
No it's a feature, there is no "top" or "bottom" in space and a Crew might float head up side down ;)

Dan

Yeah, but this is a mirror image. Unless of course you have an "Alien Queen" aboard your ship and she turns you inside out.

Looks like:   AV3 instead of EVA... This is at the "ship's bottom" of the EVA airlock looking up.


"Sun Dog"

Offline JackJL

  • Jr. Member
  • **
  • Posts: 22
  • Karma: 0
Reply #89 - 12 December 2009, 18:13:46

UCGO BUG


Bug with:

Arrow


Short description:

Parts working when crew are dead


Severity

Minor


Complete description

Even if all crew are dead the retro rockets and the backwards RCS are still controllable. Also the OFF button in the VC is
still active and shows the help pages. The help button is inactive


Reproduce bug

Kill the crew and fire the retro rockets with the normal controls.



Offline Dambuster

  • Jr. Member
  • **
  • Posts: 39
  • Karma: 0
Reply #90 - 12 December 2009, 21:12:53
Quote
JackJL wrote:

UCGO BUG


Bug with:

Arrow


Short description:

Parts working when crew are dead


Severity

Minor


Complete description

Even if all crew are dead the retro rockets and the backwards RCS are still controllable. Also the OFF button in the VC is
still active and shows the help pages. The help button is inactive


Reproduce bug

Kill the crew and fire the retro rockets with the normal controls.


I've found that this happens with any ship, when I use my joystick (and I use FlyByWire).


Offline Murdock

  • Jr. Member
  • **
  • Posts: 44
  • Country: Italy it
  • Karma: 0
Reply #91 - 12 December 2009, 21:38:31
Quote
DanSteph wrote:
AAaaah I think I get it, please do this below careffully.

7-Test Orbiter & magic , it work :)

Dan

Dan,
I followed your instructions and.....

7-Test Orbiter & magic , it work :)

I don't even ask how you did it but you're great! 8)
Problem solved!

What was it? A bug or problem with my configuration?

Also I would like to send you some pictures of my flight on the Mirage 2000, how can I do it?

I'll probably not be able to be online for 2 or 3 days (work) but I'll be right back!

Thanks Dan! :beer:



Offline JackJL

  • Jr. Member
  • **
  • Posts: 22
  • Karma: 0
Reply #92 - 12 December 2009, 22:24:02
There seems to be a minimum value of MaxSpeed for cars of 10kph. Even if lower values are defined in the config, the vehicle
will still move up to 10kph. This still happens even if MaxSpeed and/or EnginePower are 0 or negative!

It might seem strange that I want to make a car that can't move! I've been working on using a car as an anti-radiation bunker
as it can store UMMUs. I've got the flashing lights as a radiation warning

Would it be possible to have a 0 speed car? I can see this building=car being quite good for all sorts of ground base things,
especially when we could see the people inside (also in the car code).

Thanks

Jack





Offline sunshine135

  • Hero Member
  • *****
  • Posts: 547
  • Country: United States us
  • Karma: 3
  • I fly by the seat of my pants!
Reply #93 - 12 December 2009, 22:40:42
Few things I have noted in play:

I had an issue with Map not showing up around Europa. I changed from the Arrow to DGIV and brought the map up there with no
issue. Switched back to Arrow and had no issue. Guessing this is an issue with Orbiter also as I recall something like this
happening before.

I would also like to know if anyone has had an issue with wandering Ummus, especially ones inside of the base. I sort of
recall this happening before too, but it was not an issue. Now it is, because if you have an undressed Ummu- Cough, Splat, Dead.


Otherwise- no major issues noted today.


"Sun Dog"

Offline gattico

  • Sr. Member
  • ****
  • Posts: 337
  • Country: United States us
  • Karma: 15
Reply #94 - 13 December 2009, 03:23:50
Not sure if this is a bug.  But I when to a car and pressed w to set waypoints.  my heading on the car 355 degrees but
when I pressed F5 it said the waypoint bearing was -5.  I notice sometimes if the car makes a left turn the right turn signal would come on in AI mode.



Post Edited ( 12-13-09 03:28 )


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #95 - 13 December 2009, 04:16:01
Quote
sunshine135 a écrit:
Looks like:   AV3 instead of EVA... This is at the "ship's bottom" of the EVA airlock looking up.

Mhhh if you speak about this yes it's a feature, on the left a UMMU view with head "up" he can read "EVA 01" on the top of
airlock. on the right the same image but UMmu standing up side down, he still can read "EVA 01"



Dan


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #96 - 13 December 2009, 04:31:23
Quote
Murdock a écrit:
Quote
DanSteph wrote:
AAaaah I think I get it, please do this below careffully.
7-Test Orbiter & magic , it work :)
Dan
Dan,
I followed your instructions and.....
7-Test Orbiter & magic , it work :)
I don't even ask how you did it but you're great! 8)
Problem solved!

What was it? A bug or problem with my configuration?

You miss the MSVC++ redistributable in your window install (msvcr80.dll for example), this is an incomprehensible things from microsoft: the programing api of microsoft require dll installed on user's computer to work but those dll are highly optionnal in microsoft Os !????

So the thousand programmers must take care to provide them with their program (via microsoft redistributable installer) OR link statically wich mean all functions of those dll are embedded directly in each program.

Linking statically is not the recommanded practice but I don't care a cents, I never had any problem doing so with my program. For the dll cars I forgot one parameter in the compiler it was linked dynamically: no msvcr80.dll on your system: bam ! no dll loading.


You'd have the same problem with Orbiter2010 beta, martin now use as me VC2005+ wich require those dll, he solved the problem lately with Orbiter installing the ms redistributable at first orbiter launch. (RC 2.2) (which I always find offensive, I don't like installing something in user's system even microsoft things, for Orbiter2010 beta there was one case where this install messed a programmer's VC++ install, so I'll continue to provide static linked library)

Now please !!! don't install those dll in your config, you are my "bad install tester" ;)

Cheers & wow, mirage 2000 :top:

Dan



Message modifié ( 13-12-2009 04:42 )


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #97 - 13 December 2009, 04:34:39
Quote
gattico a écrit:
Not sure if this is a bug.  But I when to a car and pressed w to set waypoints.  my heading on the car 355 degrees but
when I pressed F5 it said the waypoint bearing was -5.  I notice sometimes if the car makes a left turn the right turn signal
would come on in AI mode.

Bearing is the difference beetween your current heading and the last waypoint heading... yes it's normal

Dan


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #98 - 13 December 2009, 04:47:46
Quote
gattico a écrit:

UCGO BUG
Short description:

(Can't turn and accelerate and the same time)

solved in next beta

Dan


Offline DanSteph

  • Administrator
  • Legend
  • *****
  • Posts: 15407
  • Karma: 256
  • Hein, quoi !?
    • FsPassengers
Reply #99 - 13 December 2009, 05:52:14
Quote
JackJL a écrit:

UCGO BUG
Short description:
Parts working when crew are dead

Solved in next beta, I also forbided all key (gear bay etc) and allowed only "help" button, "add crew" button
and "M" key (add crew).

Dan