See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: Orbiter DX 11 Client not working  (Read 7918 times)

0 Members and 1 Guest are viewing this topic.

Offline Razordraac

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
13 December 2012, 22:10:10
Hi guys, I'm new to this forum and I was wondering whether anyone could help me in this issue:

I downloaded the DX 11 client because I just bought a gaming PC and wanted to make the most of it but I have a problem. I tried running it but an error came up with a couple of seconds into the loading screen. It said 'Runtime Error!' and something below about 'Orbiter 2010\Modules\Server\orbiter.exe' and then below it said 'abnormal program termination' and I had no choice but to quit.

List of things that were required that I did:
I was running it on the beta
My system easily can cope with DX 11
I followed all the install procedures correctly and updates
Searched through the official Orbiter forum with no answer
Tried DX 9 - it goes on command prompt and says it's on 'server mode' and doesn't do anything
Tried DX 7 - it goes on the loading screen like DX 11 but crashes with 'orbiter.exe has stopped working' but not the 'Runtime Error'

But still, nothing works DirectX client-wise.

Any ideas?

EDIT:

Fixed it, turns out I was using the the wrong beta version.



Post Edited ( 12-14-12 19:50 )

« Last Edit: 13 December 2012, 22:10:10 by Razordraac »

Offline charvey165

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
Reply #1 - 10 August 2013, 06:35:12
ive had same issues trying to use the DX11...i have a farily new pc with dx11 installed. which version of orbiter did you use?
charvey

Edit: here is my orbiter log. i get a error that DX is missing a .dll.
**** Orbiter.log
Build Nov  5 2011 [v.111105]
Timer precision: 4.66615e-007 sec
Found 0 joystick(s)
Module AtlantisConfig.dll .... [Build 111105, API 111105]
Module AtmConfig.dll ......... [Build 111105, API 111105]
Module DGConfigurator.dll .... [Build 111105, API 111105]
Module transx.dll ............ [Build 100905, API 100905]
Module LuaMFD.dll ............ [Build 111105, API 111105]
Module CustomMFD.dll ......... [Build 111105, API 111105]
Module ScnEditor.dll ......... [Build 111105, API 111105]
Module ExtMFD.dll ............ [Build 111105, API 111105]
============================ ERROR: ===========================
Failed loading module Modules\Plugin\D3D11Client.dll (code 126)
[Orbiter::LoadModule | .\Orbiter.cpp | 612]
===============================================================

« Last Edit: 10 August 2013, 07:04:12 by charvey165 »

Offline NASSAC

  • Full Member
  • ***
  • Posts: 123
  • Karma: 0
Reply #2 - 12 November 2013, 02:48:00
I am trying to get DX 11 working with Orbiter NG. I have a windows 7 64 bit machine with dx11. I downloaded the client and copied the files into Orbiter as suggested. Prior to copying the DX11 Client files to my Orbiter foler I updated Orbiter to the latest BETA version. I selected the 3DClient in the Modules section and in the Video section I click on the D3D11Client Configuration button  and in the General tab set Anti-Aliasing to MSAA x8, T8reading = Single Sketchpad mode = D3D11PAd for back buffer only and MFD textures = Linear filtration and MFD transparency = 50%
On the Vessel tab I left MIP mapping to full and selected Texture filtration = Anisotropic x8 and left all the Extended vessel texture mapping boxes checked. IN the Planets tab I set Planet textures to Anisotropic to x8.

When I run it in widowed mode of course It begins to load then I either get a program ended unexpectedly  error, or it just hangs when it gets to loading the transparency .DDS file.

Any suggestions from anyone how I might begin to rectify this would be greatly appreciated. 

NASSAC DIRECTOR
John

Offline NASSAC

  • Full Member
  • ***
  • Posts: 123
  • Karma: 0
Reply #3 - 12 November 2013, 03:19:03
I checked out my Orbiter Log file and I found a lot of texture not found errors. I do not know why. I do not get these errors in just running orbiter only Orbiter NG. It appears that I need to load some other textures files for the Cape but I do not know which ones or where to get them.


**** Orbiter.log
Build Nov  3 2012 [v.121103]
Timer precision: 2.69958e-007 sec
Found 2 joystick(s)
Module AtlantisConfig.dll .... [Build 121103, API 121103]
Module AtmConfig.dll ......... [Build 121103, API 121103]
Module DGConfigurator.dll .... [Build 121103, API 121103]
Module OrbiterSound.dll ...... [Build 121120, API 100830]
Module D3D11Client.dll ....... [Build 120603, API 111105]

**** Creating simulation session
D3D11Client - version RC34.90, built Jun  3 2012 is starting up...
D3D11Client::clbkGetViewportSize
D3D11Client::clbkFullscreenMode
Joystick throttle: SLIDER 0
Joystick throttle control detected
Texture not found: Fcd07_n.dds
Texture not found: Fcd07_n.dds
Texture not found: Fcd08_n.dds
Texture not found: Fcd08_n.dds
Texture not found: Fcd09_n.dds
Texture not found: Fcd09_n.dds
Texture not found: Fcd10_n.dds
Texture not found: Fcd10_n.dds
Texture not found: Fcd14_n.dds
Texture not found: Fcd14_n.dds
Texture not found: Fcd15_n.dds
Texture not found: Fcd15_n.dds
Texture not found: Roof01_n.dds
Texture not found: Roof01_n.dds
Texture not found: Roof02_n.dds
Texture not found: Roof02_n.dds
Texture not found: Wall01_n.dds
Texture not found: Wall01_n.dds
Texture not found: Door01_n.dds
Texture not found: Door01_n.dds
Texture not found: Solpanel_n.dds
Texture not found: Solpanel_n.dds
Texture not found: Runway2_n.dds
Texture not found: Runway2_n.dds
Texture not found: Ball_n.dds
Texture not found: Ball_n.dds
Texture not found: Cape17_n.dds
Texture not found: Cape17_n.dds
Texture not found: Cape18_n.dds
Texture not found: Cape18_n.dds
Texture not found: Cape19_n.dds
Texture not found: Cape19_n.dds
Texture not found: Cape20_n.dds
Texture not found: Cape20_n.dds
Texture not found: Cape21.dds
Texture not found: Cape21.dds
Texture not found: Cape21_n.dds
Texture not found: Cape21_n.dds
Texture not found: Cape22_n.dds
Texture not found: Cape22_n.dds
D3D11Client::clbkFullscreenMode

NASSAC DIRECTOR
John

Offline Fast_toche

  • Legend
  • ******
  • Posts: 1329
  • Country: France fr
  • Karma: 34
  • Time is nothing...
Reply #4 - 12 November 2013, 06:02:08
Dx11 is good for the bêta of orbiter 2010!!!
and Dx9 is good for the actual orbiter 2010, right now?
>>That's the way
With google traduction!! ;)


Offline NASSAC

  • Full Member
  • ***
  • Posts: 123
  • Karma: 0
Reply #5 - 13 November 2013, 01:45:12
I am sure it is but I can't get it to work on my system. Orbiter 2010 works fine but NG crashes as per above post. I know others had problems but I have seen nothing that talks about how the problems were resolved. In the mean time I will continue to hunt for the problem. I am sure it is with something I did or did not do, but what that could be at this point I am not sure.  Thanks

NASSAC DIRECTOR
John

Offline Cras

  • Full Member
  • ***
  • Posts: 101
  • Country: United States us
  • Karma: 3
Reply #6 - 15 November 2013, 00:14:35
back when I was testing the Dx11 client out I needed to use Orbiter Beta, not 2010p1.  That is probably your problem.

Orbiter | SSMS2007 | FSX

Offline NASSAC

  • Full Member
  • ***
  • Posts: 123
  • Karma: 0
Reply #7 - 15 November 2013, 07:07:27
Thanks, but I'm using the Beta version. See reply#2.

NASSAC DIRECTOR
John

Offline NASSAC

  • Full Member
  • ***
  • Posts: 123
  • Karma: 0
Reply #8 - 30 November 2013, 01:08:34
Still cannot get orbiter ng to work, I have tried a total reinstallation. O am getting a lot of "texture not found errors" in the log file. Have no idea why. I installed a new orbiter, then the beta Orbiter, then the 3D client. I selected the 3D11client in Modules, set the parameters and selected a scenario but nothing I do makes a difference.

What follows is a list of the textures not found.

Texture not found: Fcd07_n.dds
Texture not found: Fcd07_n.dds
Texture not found: Fcd08_n.dds
Texture not found: Fcd08_n.dds
Texture not found: Fcd09_n.dds
Texture not found: Fcd09_n.dds
Texture not found: Fcd10_n.dds
Texture not found: Fcd10_n.dds
Texture not found: Fcd14_n.dds
Texture not found: Fcd14_n.dds
Texture not found: Fcd15_n.dds
Texture not found: Fcd15_n.dds
Texture not found: Roof01_n.dds
Texture not found: Roof01_n.dds
Texture not found: Roof02_n.dds
Texture not found: Roof02_n.dds
Texture not found: Wall01_n.dds
Texture not found: Wall01_n.dds
Texture not found: Door01_n.dds
Texture not found: Door01_n.dds
Texture not found: Solpanel_n.dds
Texture not found: Solpanel_n.dds
Texture not found: Runway2_n.dds
Texture not found: Runway2_n.dds
Texture not found: Ball_n.dds
Texture not found: Ball_n.dds
Texture not found: Cape17_n.dds
Texture not found: Cape17_n.dds
Texture not found: Cape18_n.dds
Texture not found: Cape18_n.dds
Texture not found: Cape19_n.dds
Texture not found: Cape19_n.dds
Texture not found: Cape20_n.dds
Texture not found: Cape20_n.dds
Texture not found: Cape21.dds
Texture not found: Cape21.dds
Texture not found: Cape21_n.dds
Texture not found: Cape21_n.dds
Texture not found: Cape22_n.dds
Texture not found: Cape22_n.dds
D3D11Client::clbkFullscreenMode


The program just hauls and sits there with the BETA screen for Orbiter and does nothing.

Any suggestions would greatly be appreciated.


Is there anything I can do with my graphics setting that might make a difference?

If anyone has Orbiter ng working a on a windows 7 64 bit computer I would like to hear from you, so that I can know the software will work. 

I wish there was someplace to go for more detailed explanation of Orbiter ng.

Thanks ahead of time for taking the time to read about my problem with Orbiter ng.

NASSAC DIRECTOR
John

Offline SolarLiner

  • Global Moderator
  • Legend
  • *****
  • Posts: 2769
  • Country: France fr
  • Karma: 55
  • a été remercié par Le Créateur
Reply #9 - 30 November 2013, 12:45:09
Fullscreen is not yet implemented in D3D11 AFAIK.


Offline NASSAC

  • Full Member
  • ***
  • Posts: 123
  • Karma: 0
Reply #10 - 02 December 2013, 05:17:14
I am using window mode.

NASSAC DIRECTOR
John