See site in english Voir le site en francais
Website skin:
home  download  forum  link  contact

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Author Topic: Big hello and a small problem  (Read 1470 times)

0 Members and 1 Guest are viewing this topic.

Offline yhp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
18 May 2005, 19:52:58
Hi all,

Short-time orbinaut, first time poster. I'm 26, from Manchester, UK. Programmer by trade but like to lend my hand to the dark
arts of 3D, audio and, of course, interplanetary travel. I'd tip my hat but i'm wearing a pressure suit ;)

Soo.. Searching for a good open source project to have a play with and found a lil gem called Orbiter. I'm still learning the
ropes. Mostly this involves crashing and burning or just burning.. and then crashing. Great, great fun.  Got myself all the
texture packs and wotnot. The DGIII is, as they rightly say, supreme. Gotta love leaving half your crew in orbit before hurtling
towards the ground in a firey ball. Early days yet tho!


Anyways, to the problem.. My HUD flickers occassionally. Most of the time it doesnt show at all. When it is in a
flickerin-kind-mood any keypress or user input will stop it flickering on, it just stays off. I also noticed that the
star/planet/nebulae names on planetarium mode have gone. Were they originally there or have i been smoking something i
shouldn't have??

Few more intricacies....

1. If i set it to transparent HUD then it will stay on yet flicker at about once per sec. Changing the HUD refresh rate
doesnt do a thing.
2. This problem hasnt been evident all the time. Only started to happen two days ago.
3. I've completly wiped the orbirer directory and reinstalled. Doesnt seem to make a difference!
4. Virtual HUDs are fine, no probs there.
5. I've tried switching colours, on/off, etc to no avail
6. When its flickerin my FPS drops by a factor of 10!

I have plenty of power in the PC. Its a 3.5Ghz AMD64, N-Force4, GeForce 6800 Ultra, 1Gb RAM and a Saitek Cyborg 3D USB stick,
DirectX 9c (managed, retail version)..  I'm getting 225fps with all mod-cons, res up to full and the lvl9 earth tex (however
when its flickerin it drops to 25!!)

The panels and MFDs are unaffected.  Also the linear/rotational thruster selection is unaffected.

I have a feeling it could be directX as its affecting other font rending (planetarium, ship-lock, even the fps). If anyone
has any fixes for this problem please, please let me know!


Mike

PS... Dan, virtual cockpit on DGIII.. Everybody is right. Bring it on!! :)



Post Edited ( 05-18-05 20:03 )


Offline DocHoliday

  • Legend
  • ******
  • Posts: 2474
  • Karma: 1
Reply #1 - 19 May 2005, 14:50:27
Monstrous machine there, mate :) I'm still on the punny Athlon 1.5gig.

I never had this sort of problem, but I've seen people give and get advice on anti-aliasing...? Could that be affecting
it? Also perhaps the overlay feature may have a problem.. I'm just suggesting a course of action, I have NO idea
otherwise on how to solve these issues.


~~~

"Mood is a matter of choice. I choose to have fun!" -Vidmarism No 15

Offline freespace2dotcom

  • Legend
  • ******
  • Posts: 2251
  • Karma: 1
Reply #2 - 19 May 2005, 15:02:21
Ah, I remember that many others and even I had that problem, if you search the archives, you're likely to find it. I'd
help you, but I'm currently engaged in schoolwork of the electrical kind.

it is fixable, and although I confess you've a doozy of a processor, my consolation lies in the fact the orbiter's still 32
bit. :)

that and a 2.8 gig'er isn't that far off from you. ;)



Offline yhp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Reply #3 - 19 May 2005, 19:33:08
I did a good thorough search before posting. Doesnt seem to be anything about a flickering HUD problem tho. Unless i'm
looking in the wrong place. If you could suggest the location of these archives it would be appreciated. The main orbiter forum was offline until i just tried it 2 secs ago.. Will have a look through there!

I was using the Nvidia application control settings to whack the anti-aliasing up to 16x and force some funky features
(Orbital looks even better i tell ya) but have disabled it since the problem started. It was working fine for a week with it
on tho so i dont think it will be that.

I could have gone down the 32bit route but i wanted an SLI bridge (need to save my pennies for the second 6800 tho lol),
proper PCI express and a good RAID SATA2 implementation. It all wasnt that expensive either tbh. My last desktop died a death
and have been running off my laptop (albeit a 3Ghz P4) which are not known for gaming performance (although only really
suffers with DirectX9 compatability). Desperatly wanted a games machine and just had a promotion so i went out treated myself ;)



Post Edited ( 05-19-05 19:43 )


Offline yhp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Reply #4 - 19 May 2005, 19:52:29
Hi again... problem solved!

Problem with Nvidia cards and AA settings... Strange how it worked fine for a good few days!

Anyhows..... http://orbit.m6.net/v2/read.asp?id=21583


Cheers,

Mike



Offline Simonpro

  • Hero Member
  • *****
  • Posts: 546
  • Karma: 0
Reply #5 - 19 May 2005, 21:12:14
The other problem with AA and orbiter is that all the darn stars tend to disappear ;)


-------------------------------

Offline MattNW

  • Sr. Member
  • ****
  • Posts: 333
  • Karma: 0
Reply #6 - 22 May 2005, 04:58:47
Did you change from Window mode to full screen? Some video cards will let the HUD work in window mode but not in
full screen with AA turned on.

« Last Edit: 22 May 2005, 04:58:47 by MattNW »